1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

fastCGI 500 Server error

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Jan.S, Oct 3, 2009.

  1. Jan.S

    Jan.S Guest

    0
     
    Hello,

    I activate fastCGi on 2 Domains. But fastCGI work only with 1 Domain. Its work with this Domains how become the first request.
    The Second domain become a 500 Internal Server error.

    I see with "top"

    10112 *** 19 0 0 0 0 Z 0 0.0 0:00.01 php5-cgi <defunct> <-- second request

    Why can start only one php5-cgi prozess?

    and Why don´t die the other php5-cgi prozess?

    I have
    Ubuntu 6.06
    Plesk 9.2.2
    2GB RAM
     
  2. igors

    igors Basic Pleskian

    20
    37%
    Joined:
    Sep 1, 2009
    Messages:
    32
    Likes Received:
    0
    Hi,

    And what errors do you see in domain apache error log when you get "500 Internal Server error" in browser?

    Apache error log for domain is located under $VHOST_DIR/DOMAIN_NAME/statistics/logs/error_log

    Here $VHOST_DIR is path to virtual hosts content. You can get this path from config file, for example:
    # grep VHOST /etc/psa/psa.conf
    HTTPD_VHOSTS_D /var/www/vhosts

    So check error log, perhaps it will give more clues about this problem.

    Also make sure you do not have apparmor enabled on your server. Apparmor is not compatible with Parallels Plesk and can cause unpredictable behavior of web/mail and other services.
     
  3. Jan.S

    Jan.S Guest

    0
     
    The Problem was the PHP version 5.2.4

    The Solution was

    /etc/php5/cgi/php.ini

    cgi.fix_pathinfo = 0;

    Thx for reading :D
     
Loading...