1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Fedora Core 6 x64 version with Plesk

Discussion in 'Plesk for Linux - 8.x and Older' started by edcarriere, Mar 31, 2007.

  1. edcarriere

    edcarriere Guest

    0
     
    I found something out that I did not know about the x64 version of Fedora Core 6. Once you install it and do the updates/upgrades, the system blocks binary files from being executed as programs.

    When trying to install plesk 8.1.1 (FC64x64), it would always give me ¨cannot execute binary file¨. This was also happening after I had disabled SELinux. I followed all of the online instructions and nothing worked...

    I found out that doing chmod +x on the psa* file changes the permissions but does not allow you to execute the binary file.

    You must use the FC6x64 ¨file browser¨, locate the file, right click the psa* file, in the permissions tab set the ¨allow executing file as a program¨ and also change the SELinux setting to ¨temporary data¨ from ¨file_t¨.

    This will allow you to install plesk without problems from what I can see...
    I never had this kind of problem with the 32bit version, only the x64 versions...

    Ed
     
  2. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    How do you do this when you have no GUI on the system?
     
  3. edcarriere

    edcarriere Guest

    0
     
    No GUI

    I think you might be able to use mc to do the same thing but I am not 100% sure of that. You would need to use a file manager of some sort to change the permission so that it works...

    I do not know why it was made that way by fedora core 6 x64...
     
  4. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    I also had:

    ¨cannot execute binary file¨

    On closer inspection it turns out I was trying to run a 64-bit executable on a 32-bit system.

    The key was to use the following command:

    Code:
    [root@cp3 swsoft]# uname -a
    Linux cp3.snowballeffect.net 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:39:22 EDT 2006 [b]x86_64 x86_64 x86_64 GNU/Linux[/b]
    
     
  5. edcarriere

    edcarriere Guest

    0
     
    x64

    If you think you have a 32 bit system then you should not be using the x64 bit OS. But if your system is a x64 bit system, then the OS is correct.

    Try installing one of Fedora's graphic desktops. Then use "nautilus" to take care of the file permissions.

    My system says:

    uname -a
    Linux echo1.wwwemailhost.com 2.6.20-1.2952.fc6 #1 SMP Wed May 16 18:18:22 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux
     
Loading...