1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Fix Webmail Not Found 404 Error

Discussion in 'Plesk for Windows - 8.x and Older' started by owebtech, Oct 27, 2004.

  1. owebtech

    owebtech Guest

    0
     
    If you are getting an error that says
    File cannot be found or a 404 error when you try to go to webmail.mydomain.com, this may help you out.

    The error occured right after i set "enable parent paths" to true on the website folder of iis.
    The problem was that the default mapping options overwrote ALL of my domains, including webmail.

    The problem is that the default mapping application extensions do not include php support.

    Here is how to fix this:
    Go to start - > Administrative Tools -> Internet Information Services (IIS) Manager

    Expand the server (local computer)

    Expand Web Sites

    Right click on webmail(default) and click Properties

    Go to the Home Directory tab

    Click on the Configuration button towards the bottom.

    In the list box that appears, if the extensions php, php3, and phtml do not exist, you have found your problem.

    Click Add

    For executable, type the location of the file php.exe
    mine was: "C:\Program Files\SWsoft\Plesk\Php\php.exe"
    (You need the " around the file if there is a space in the location)
    (If you cannot find it there, try searching for the file.)

    For extension, type: .php

    Leave everything else as default checked. Click ok.

    Repete this step using the same executable and adding the extensions: .php3 and .phtml

    Exit out of everything. Webmail should be up and running now.

    If it didnt help, im very sorry :(. If it did, great :). Let me know if there is anything else i can do for you folks.
     
  2. asifrizvi

    asifrizvi Guest

    0
     
    need more help dear...

    Hi, first of thanx for this but i'm facing different problem i just check what ever you told us in this thread its okey with my settings but still i'm having this error when i check webmail.mydomain.com:

    You are not authorized to view this page

    HTTP Error 403 - Forbidden

    I'm using Plesk 7 windows + powerpack with mailenable standard.

    If you help me in this it'll be great help. even the planet guyz not resolving this....:confused: :eek:
     
  3. owebtech

    owebtech Guest

    0
     
    forbidden error

    Well, a 403 is a forbidden access error which almost seems like you are not allowing access to the webmail site. Try this:

    Go to start -> Admin Tools -> Internet Information Services (IIS) Manager

    Expand the server. Expand Web Sites and right click on webmail.

    Go to the directory security tab and click Edit in Authentication and access control.

    Make sure Enable anonymous access is checked and that the username and password is filled in. The username should be the iis user for that server. Mine, for example is: IUSR_SERVER70

    If that is all good, try going to C:\Inetpub\vhosts and right clicking on the webmail folder. Click on Sharing and Security and go to the security tab. I have the following listed in the Group or user name box:
    Administrators
    psacln
    psaserv
    System

    I am not 100% positive, but i know that the psacln and psaserv need "read & execute", "List folder Contents", and "read" permissions.

    If those are set, you may have other security featured that i am not aware of enabled (or disabled).

    Hope that helps.
     
  4. asifrizvi

    asifrizvi Guest

    0
     
    thanx man

    thank you very much its working now ...
    regards,
    :cool: Asif Rizvi :)
     
  5. VictorySaber

    VictorySaber Guest

    0
     
    I have the same problem.. in Plesk 7 for Windows and the extensions .php and the others are already set by default.

    When i check the IIS the first time i found that the Home Directory patch was F:\inetpub\vhosts\\webmail\horde this is incorrect and a second slash appeared before webmail so i just removed this slash but the webmail still not work for any of my domains.

    I also try to fix the problem with the solution found at the faq but it looks like only works for Plesk 7.5

    http://faq.sw-soft.com/article_155_968_en.html

    Please advice! :(
     
Loading...