1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

found some error into phpmyadmin after upgrade to plesk 10.4.4

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by EdwardDekker, Nov 23, 2011.

  1. EdwardDekker

    EdwardDekker Guest

    0
     
    CENTOS 5.7 i386
    PLESK v10.4.4_build1013111102.18 os_CentOS 5

    After a upgrade of Plesk 10.3.1 to Plesk 10.4.4.
    Do I get this error, look like a bug too me.

    Code:
    Your PHP parameter [URL="https://edwarddekkerhosting.nl:8443/domains/databases/phpMyAdmin/url.php?url=http%3A%2F%2Fphp.net%2Fmanual%2Fen%2Fsession.configuration.php%23ini.session.gc-maxlifetime&token=98168903981323eccbe9ead175d2413e&phpMyAdmin=dfcbf279786eb3fa301ab5d7d21f3c42e9daee3f"]session.gc_maxlifetime[/URL]  is lower that cookie validity configured in phpMyAdmin, because of  this, your login will expire sooner than configured in phpMyAdmin.
    
     
    Last edited by a moderator: Nov 23, 2011
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Check value for session.gc_maxlifetime parameter in php.ini and compare it with $cfg['LoginCookieValidity'] parameter in config.inc.php of phpmyadmin. Try to set it equal.
     
  3. EdwardDekker

    EdwardDekker Guest

    0
     
    I have looked into my php.ini files and do not see any faults.
    When i look to phpMyAdmin settings, these are fine too, except that I can't find config.inc.php into the root of phpMyAdmin.

    config.default.php:
    Code:
    [root@server]# grep 'LoginCookieValidity' /usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin/libraries/config.default.php
     * @global integer $cfg['LoginCookieValidity']
    $cfg['LoginCookieValidity'] = 1440;
    
    /etc/php.ini
    Code:
    [root@server]# grep 'session.gc_max*' /etc/php.ini
    session.gc_maxlifetime = 1440
    ;       setting session.gc_maxlifetime to 1440 (1440 seconds = 24 minutes):
    
    /usr/local/psa/admin/conf/php.ini (I add the session.gc_maxlifetime into this php.ini)
    Code:
    [root@server]# grep 'session.gc*' /usr/local/psa/admin/conf/php.ini
    session.gc_maxlifetime = 1440
    
    When I change the session Idle Time @ Plesk itself into 'tools & settings' to 24 minutes.
    The warning of phpMyAdmin will disappears.
     
    Last edited by a moderator: Nov 24, 2011
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Did you try to increase this value for phpmyadmin config?
     
  5. EdwardDekker

    EdwardDekker Guest

    0
     
    yes i have increased the value, but then no results into the old and new situation.
     
    Last edited by a moderator: Nov 24, 2011
  6. EdwardDekker

    EdwardDekker Guest

    0
     
    On the second thought, maybe could the cookies of Plesk involved my phpMyAdmin configuration and show a error when I'll have changed the session idle time of Plesk or phpMyAdmin.
     
Loading...