1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

fresh install -> Couldn't resolve host

Discussion in 'Plesk for Linux - 8.x and Older' started by Jerry69, Dec 14, 2004.

  1. Jerry69

    Jerry69 Guest

    0
     
    I am doing a fresh install of plesk 7.5
    with the auto install script
    i get to step 3 and:

    i can't for the life of me figure it out
    the only thing installed is:
    Fedora core 2

    i've followed everything to a T
    including using the same directories given in the example

    Can anyone help?
    tia
     
  2. Mr. Pink

    Mr. Pink Guest

    0
     
    Hi,

    does your internet connection work?

    Code:
    zum:~ # nslookup -sil autoinstall.plesk.com
    Server:         81.3.5.85
    Address:        81.3.5.85#53
    
    Non-authoritative answer:
    Name:   autoinstall.plesk.com
    Address: 69.64.46.31
    
    server1:~ #
    
    Regards,

    Pink
     
  3. chickenbak

    chickenbak Guest

    0
     
    You need an internet connection...

    type

    resolveip autoinstall.plesk.com

    and see what it says.
     
  4. Jerry69

    Jerry69 Guest

    0
     
    when i run:
    resolveip autoinstall.plesk.com
    it says:
    resolveip: Unable to find hostid for 'autoinstall.plesk.com': try again


    and when i run:
    nslookup -sil autoinstall.plesk.com
    it says:
    ;; connection timed out; no servers could be reached


    I am in Canada, my webserver is in Hong Kong, I am obviously getting an internet connection, but plesk install is not,,, how can this be?
    do i have to modify the file:
    psa_installer_v2.0.0_build75041129.17_os_FedoraCore_2_i686
    in some way?
     
  5. chickenbak

    chickenbak Guest

    0
     
    No, what is obvious is that you don't know a thing about the server you are trying to administrate. If you run resolveip, and nslookup, and it doesn't resolve and times out...then obviously your dns servers aren't working on your end. Do a resolveip google.com, see if it comes back with anything.

    So far you have failed to deduce by your own test runs, THAT IT ISN'T PLESK. It's obviously a failure on your host's part to configure your dns correctly.

     
  6. Jerry69

    Jerry69 Guest

    0
     
    chickenbak,
    I can see how my wording "obviously" sounded like some kind of spiteback...

    it wasn't intened to be at all...
    what i meant to say/how i wanted that wording to be taken was:

    it is obvious to me that it has a connection between me and the root server, but plesk doesn't have one between it and my server, how can this be?

    there is absolutely NO WAY, i would want to sound sarcastic to someone that is trying to help an extreme newbie like myself...

    I knew something was wrong,,, I followed everything to a T in the install, and it didn't work, if plesk was to blame, this problem would be posted all over, which it isn't.
    I figured it had to be something to due with my servers ports or it's ability to communicate with the net, or something like that.

    I would never bite a gift horse in the mouth...
    my apologise to anyone i inadvertantly offended..

    i came here for help, not to offend anyone
     
  7. chickenbak

    chickenbak Guest

    0
     
    And my response to you is still accurate, it is obvious that your server doesn't have the dns servers setup correctly. When you type resolveip autoinstall.plesk.com and it doesn't resolve, that is because of the server itself, not because of Plesk. The same goes for your nslookup command, the reason it isn't working is because of your server, not because of plesk...if you type resolveip google.com, you can verify that.

    Now what you need to do is get your host to finish setting up the dns servers, obviously they never did it. You server still needs to translate canonical names etc into something it can use (ips)...now the only other way that you will be able to get it working without the dns working correctly is by doing the following...

    Add this line to your /etc/hosts file...

    69.64.46.31 autoinstall.plesk.com

    That should allow your server to resolve the hostname without looking it up, and get you through the installation, but that is a band-aid fix to your real problem, your dns servers aren't setup. Tell me if it works out.
     
  8. Jerry69

    Jerry69 Guest

    0
     
    Hi Chickenbak,
    I did what you told me to, and tried the resolveip with google and it errored as well, so i emailed my host to ask him to help me out with it, this is his reply:

    he did this for me, and it resolves perfectly.
    (although the secondary ip still timesout when trying to connect through telnet. but i can work on that later)

    thanks very much for your help
    don't know where i'd be without these forums and people like you :)
     
  9. chickenbak

    chickenbak Guest

    0
     
    Not a problem at all, you are more than welcome. And this was a "silver lined cloud" as they say, since it also got your host to make sure your dns was working correctly.

    If you have any other issues, don't hesitate to ask!

     
Loading...