1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

ftp client doesnt finish upload

Discussion in 'Plesk for Linux - 8.x and Older' started by dave_s_wang, Dec 3, 2005.

  1. dave_s_wang

    dave_s_wang Guest

    0
     
    ftp client cant connect

    Im having a problem connecting to my ftp server via passive ftp.

    this is the log:
    Connected with ****.biz. Waiting for welcome message...
    Response: 220 ProFTPD 1.2.10 Server (ProFTPD) [***.***.***.****]]
    Command: USER *****
    Response: 331 Password required for ****.
    Command: PASS *******
    Response: 230 User **** logged in.
    Command: FEAT
    Response: 211-Features:
    Response: MDTM
    Response: REST STREAM
    Response: SIZE
    Response: 211 End
    Command: SYST
    Response: 215 UNIX Type: L8
    Status: Connected
    Status: Retrieving directory listing...
    Command: PWD
    Response: 257 "/" is current directory.
    Command: TYPE A
    Response: 200 Type set to A
    Command: PASV
    Response: 227 Entering Passive Mode (***,***,***,***,***).
    Command: LIST
    Error: Transfer channel can't be opened. Reason: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    Error: Could not retrieve directory listing
    Command: TYPE A
    Error: Timeout detected!

    I have a feeling it has something to do with my firewall rules. what rules should I have on my firewall? it seems to connect, but then the conenction is dropped.

    Also, I have these lines entered in /etc/proftpd.include:
    PassivePorts 49152 65534

    Thanks in advance
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    You don't say what firewall you are using. But from your post, it is clear that the ftp client was denied from using passive ports, so yes, you need to add firewall rules to open up the ports you specified in the proftpd.conf file.

    For RH type linux IPTABLES it would look something like:
    This would be in the /etc/sysconfig/iptables config file.

    If you are using the Plesk Firewall Module (just a GUI frontend for iptables), you cannot modify the config file directly, you must enter the ports in the GUI (AFAIK one port at a time, unless they have finally fixed that, but I doubt it).
     
  3. cmaxwell

    cmaxwell Regular Pleskian

    25
    73%
    Joined:
    Aug 1, 2001
    Messages:
    150
    Likes Received:
    1
    One of our servers is having a similar problem. It begins file uploads and after about 1MB of data transfer the connection drops.

    If we disable the iptables firewall then it works fine.

    I set the passive ports in /etc/proftpd.conf:

    PassivePorts 49152 65534

    And opened the ports in the firewall:

    /sbin/iptables -A INPUT -p tcp -m tcp --dport 49152:65534 --syn -j ACCEPT

    Other than this we don't have any other customisations on the firewall.

    Any ideas? I'm guessing it's a problem with the firewall but find it very strange that it starts the file transfer then stops.

    Thanks.

    - Chris
     
  4. cmaxwell

    cmaxwell Regular Pleskian

    25
    73%
    Joined:
    Aug 1, 2001
    Messages:
    150
    Likes Received:
    1
    I'll repost this in a new thread as it isn't really the same issue as the original thread, sorry to go off topic.
     
Loading...