1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

FTP Problems

Discussion in 'Plesk for Windows - 8.x and Older' started by hollywoodjrc, May 9, 2005.

  1. hollywoodjrc

    hollywoodjrc Guest

    0
     
    Every time we've tried to connect to one of our FTP sites, we run into the following problem(s). Does anyone know how to work around this?

    Thank you!

    *** CuteFTP Pro 3.3 - build Sep 29 2003 ***

    STATUS:> Getting listing ""...
    STATUS:> Resolving host name myhostname.com...
    STATUS:> Host name myhostname.com resolved: ip = 66.225.***.***.
    STATUS:> Connecting to ftp server myhostname.com:21 (ip = 66.225.***.***)...
    STATUS:> Socket connected. Waiting for welcome message...
    220 Microsoft FTP Service
    STATUS:> Connected. Authenticating...
    COMMAND:> USER myusername
    331 Password required for myusername.
    COMMAND:> PASS *****
    230 User myusernamelogged in.
    STATUS:> Login successful.
    COMMAND:> PWD
    257 "/" is current directory.
    STATUS:> Home directory: /
    COMMAND:> FEAT
    211-FEAT
    SIZE
    MDTM
    211 END
    STATUS:> This site supports features.
    STATUS:> This site supports SIZE.
    COMMAND:> REST 100
    350 Restarting at 100.
    STATUS:> This site can resume broken downloads.
    COMMAND:> REST 0
    350 Restarting at 0.
    COMMAND:> PASV
    227 Entering Passive Mode (66,225,***,***,4,15).
    COMMAND:> LIST
    STATUS:> Connecting ftp data socket 66.225.***.***:1039...
    ERROR:> Can't connect to remote server. Socket error = #10060.
    425 Can't open data connection.
    ERROR:> Trashed response received.
     
  2. knocx

    knocx Guest

    0
     
    Try stopping and disabling "Routing and Remote Access" from Windows Services console

    i had had such an issue and worked a week to debug and resolve this.

    let me know if that helps cause i plan to sue Microsoft for adding such garbage services and causing runtime failiures :)


    -- kncocx
     
  3. hollywoodjrc

    hollywoodjrc Guest

    0
     
    That worked wonderfully!

    Thank you so much for your help! I was about ready to rip out every firewall and eventually start from scratch because I was so frustrated.


    Thanks again!
     
  4. knocx

    knocx Guest

    0
     
    I understand you... last month i had worked on that for a week every night!

    i really want to meet XP , Win 2003 & .NET developer guys to spit on them :mad:


    the worst OS ever is XP , and win03 is the second


    --knocx
     
  5. atinoco

    atinoco Guest

    0
     
    I'm troubleshooting a similar issue with my server where the ftp client can't list the contents of a particular folder.

    I disabled the plesk firewall and now i can access it just fine.

    what did you use to replace the windows firewall? I dont feel like leaving my server without a firewall.

    Thanks in Advance
     
  6. gOOvER

    gOOvER Guest

    0
     
    Disable passive connections in your FTP Program. Enable Active Connections.
     
  7. IG0R

    IG0R Guest

    0
     
    Same thing here

    Disabling passive mode the problem number one is solved

    But the problem number two (send files bigger than 1,5mb) still on my plesk server

    Disable the firewall is not the best solution i think
     
  8. atinoco

    atinoco Guest

    0
     
  9. kuhle

    kuhle Guest

    0
     
    Please forgive me if I am asking a really sill question.

    I have a client who has uploaded a website with ftp into httpdocs. When you visit www.domain.com it comes up with a Fedora Core Test Page which says (apart from other stuff):

    If you are the website administrator:
    You may now add content to the directory /var/www/html/. Note that until you do so, people visiting your website will see this page, and not your content. To prevent this page from ever being used, follow the instructions in the file /etc/httpd/conf.d/welcome.conf.

    Neither of the 2 directories above exist in the files.

    When you visit www.domain.com/index.htm it them shows up as it should, but clearly they would only want their customers to type www.domain.com in order to get to the website.

    Can anybody help me to resolve this? Thanks in advance.
     
  10. Traged1

    Traged1 Guest

    0
     
    You should make sure that the account has .htm listed in the "Directory indexes" for IIS manager.
     
  11. Traged1

    Traged1 Guest

    0
     
    The main problem is that some people who are behind firewalls or routers need passive transfer mode to reach the ftp server, why does it not work, is there a bug?
     
  12. Traged1

    Traged1 Guest

    0
     
    It appears to be a bug in IIS ftp, it appears that using the "-" hyphen character is stalling the passive ftp transfer LIST action. You should either try using active transfers or renaming any files with the hyphen in them, the underscore character does not reproduce the same problem, so I wouls suggest renaming the files with - to _ untill microsoft fixes this bug?
     
Loading...