1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

GD Library on fresh plesk installation

Discussion in 'Plesk for Linux - 8.x and Older' started by jhohman, Sep 15, 2005.

  1. jhohman

    jhohman Guest

    0
     
    Okay, I've been trying to get this to work for 5 or 6 hours, and I've all but given up.

    For some reason, plesk didn't install GD on my Fedora Core 3 server, so I decided to take matters into my own hands. I downloaded GD, compiled and installed it. Then I downloaded php (4.4.0, also tried the newest version), and compiled it. Now if I run "php -m" the "gd" module shows in the list, but if I run a script with "phpinfo()" in it, it doesn't show the gd module.

    Here's what I used to configure PHP:
    ./configure --build=i386-redhat-linux --host=i386-redhat-linux \
    --target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr \
    --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin \
    --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include \
    --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var \
    --sharedstatedir=/usr/com --mandir=/usr/share/man \
    --infodir=/usr/share/info --cache-file=../config.cache \
    --with-config-file-path=/etc --with-config-file-scan-dir=/etc/php.d \
    --enable-force-cgi-redirect --disable-debug --enable-pic --disable-rpath \
    --enable-inline-optimization --with-bz2 --with-db4=/usr --with-curl \
    --with-exec-dir=/usr/bin --with-freetype-dir=/usr --with-png-dir=/usr \
    --with-gd=shared --enable-gd-native-ttf --without-gdbm --with-gettext \
    --with-ncurses=shared --with-gmp --with-iconv --with-jpeg-dir=/usr \
    --with-openssl --with-png --with-pspell --with-xml --with-expat-dir=/usr \
    --with-dom=shared,/usr --with-dom-xslt=/usr --with-dom-exslt=/usr \
    --with-xmlrpc=shared --with-pcre-regex=/usr --with-zlib --with-layout=GNU \
    --enable-bcmath --enable-exif --enable-ftp --enable-magic-quotes \
    --enable-sockets --enable-sysvsem --enable-sysvshm --enable-track-vars \
    --enable-trans-sid --enable-yp --enable-wddx --with-pear=/usr/share/pear \
    --with-kerberos --with-ldap=shared \
    --with-mysql=shared,/usr \
    --enable-ucd-snmp-hack --with-unixODBC=shared,/usr \
    --enable-memory-limit --enable-shmop --enable-calendar --enable-dbx \
    --enable-dio --enable-mbstring=shared --enable-mbstr-enc-trans \
    --enable-mbregex --with-mime-magic=/usr/share/file/magic.mime --with-pic \
    --with-apxs=/usr/local/psa/admin/bin/apxs \
    --with-jpeg-dir=/usr/lib \
    --with-png-dir=/usr/lib \
    --with-gd

    Any idea what I'm doing wrong? Is there anything else I can submit to help?
     
  2. Redah

    Redah Guest

    0
     
    You could have just installed the php-gd rpm you know...

    Code:
    [root@epona ~]# rpm -qa | grep -i php
    php-pgsql-4.3.11-2.7
    [b]php-gd-4.3.11-2.7[/b]
    php-imap-4.3.11-2.7
    php-4.3.11-2.7
    php-mysql-4.3.11-2.7
    
     
  3. jhohman

    jhohman Guest

    0
     
    Thank you, that's the exact information I needed to know. Sorry for being a n00b.
     
  4. Redah

    Redah Guest

    0
     
    No problem, took me a few days before Google stumbled upon a website that helped me out :)
     
  5. poke

    poke Guest

    0
     
    Redah,
    What might this website be? Is there a source other than ART for plesk friendly RPMs?
     
  6. memphishost

    memphishost Guest

    0
     
  7. Redah

    Redah Guest

    0
     
    This isn't a plesk-friendly RPM really, it's included by default in FC2 and FC3 (perhaps FC1 too, I don't know). But, coming from Redhat installations, I always assumed GD was compiled into the default PHP RPM.

    As it turns out (some message board on redhat.com had a thread about it) they seperated GD from PHP in the Fedora distributions and put it in a seperate RPM. Shame it isn't documented somewhere, though.

    So, the RPMs I listed are all default FC3 RPM's, and they work perfectly with Plesk. I also have the default MySQL 4 RPMs installed, also work beautiful, instead of the ones from ART.
     
Loading...