1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Help! Problem in Namecheap module

Discussion in 'Customer&Business Manager (formerly Plesk Billing)' started by totiherms, Mar 22, 2011.

  1. totiherms

    totiherms Guest

    0
     
    Hi,

    I'm trying to register a new domain through the namecheap module. I'm testing in the sandbox environment. I'm trying to register a new domain with my own nameservers, choosing YES to the Use custom nameservers in the settings module. I can register a new domain, but I can't add my own nameservers to it. I can see in the debug that the api call is:

    http://api.sandbox.namecheap.com/xml.response?ApiUser=totiherms&ApiKey=apikey&UserName=totiherms&Command=namecheap.domains.create&ClientIp=127.0.0.1&DomainName=1toti.com&Years=1&Nameservers=&RegistrantFirstName=Jordi&RegistrantLastName=herms&RegistrantOrganizationName=..........

    Note that the parameter NameServers is blank, when it has to be ns1.mydomain.com,ns2.mydomain.com.

    Other parameter: Curl->fields["Nameservers"] =

    But namecheap is configured:

    ["domain"]["registrar"]["namecheap"]["domainNameserver1"] = ns1.mydomain.com
    ["domain"]["registrar"]["namecheap"]["domainNameserver2"] = ns2.mydomain.com

    Any ideas? Why plesk billing is not sending the parameter to the namecheap api???
     
Loading...