1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

HELP! SQL Server does not exist or access denied

Discussion in 'Plesk for Windows - 8.x and Older' started by nashoba, Jun 21, 2006.

  1. nashoba

    nashoba Guest

    0
     
    I am surprised that this error is not well documented, as it seems from a quick Google search that this has been an unanswered issue for a lot of people.

    Upon trying to install Plesk version 7.6 for Windows with MS SQL Server Express 2005, I can get as far as the installation asking me for the MS SQL Server information. However, when I put in the host "localhost" (I also tried the live IP address as well), the username "sa" (I also tried creating another user with MORE permissions than "sa" originally has), and my correct password (I even reset the password several times to make sure that wasn't the issue), I am getting this precise--albeit, rather generic and unhelpful--error message:
    So far, I have tried the Knowledge Base at both SWsoft and Microsoft, I have talked to the technicians at the hosting company, and I have spent a bunch of time just going through Google and forums trying to find a solution. I also made sure that the TCP/IP protocol was enabled in the SQL Server Configuration Manager, and I restarted the SQL server after enabling. Looking in the TCP/IP Properties under the "IPAll" section, the TCP Dynamic Ports is set to 2460, so supposedly the MS SQL Server is binding a port and I should be able to connect to it through the Plesk installer, but nothing I have tried has worked.

    Please help.
     
  2. bladefx

    bladefx Guest

    0
     
    make sure that in your "Client Network Utility" the Alias is set to named pipes.
    I've found that plesk changed it to TCP/IP when upgrading.
     
  3. Deltafox

    Deltafox Guest

    0
     
    same issue over here but then i found the solution:

    Host: .\SQLEXPRESS
    User: sa
    Pass: pass

    good luck :)
     
  4. Gris@

    Gris@ Guest

    0
     
    By default after installation MSSQL 2005 has tcp/ip disabled but Plesk connects to MSSQL server usyng it.
    So that to connect MSSQL server to Plesk you need to enable tcp/ip first.
     
  5. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    Wow this post is so confusing because everyone gives a different answer. I found this article on SWSoft's forum:

    http://kb.swsoft.com/article_146_1120_en.html

    which implies enabling TCP/IP, but isn't there something else that needs to be done in order to use SQL Express?
     
  6. djkast

    djkast Guest

    0
     
    Has anyone been able to resolve this?
    I am having this same problem as well..
     
  7. a3n1ma

    a3n1ma Guest

    0
     
    I actually tried the hostname that deltafox used, and it fixed my same problem. :)
     
  8. djkast

    djkast Guest

    0
     
    nice,

    worked for me too
     
  9. thewolf

    thewolf Regular Pleskian

    25
    57%
    Joined:
    Mar 11, 2004
    Messages:
    231
    Likes Received:
    0
    This fixed my issue with Plesk 8.1 not finding the SQL Server Express 2005 database on Windows Server 2003, thanks!

    Can I ask what that host notation exactly means?

    Thanks.
     
  10. iTechSquad

    iTechSquad Guest

    0
     
    Doesn't seem to work for me :-(

    The worst part is it takes about 5 minutes of trying before Plesk realizes it can't connect ...

    I tried de IP, .\SQLEXPRESS, localhost, none work.

    I have the TCP/IP protocol enabled.

    Any further investigations done on this issue ?

    Thanks,
     
  11. JTRipper

    JTRipper Regular Pleskian

    27
     
    Joined:
    Mar 22, 2006
    Messages:
    106
    Likes Received:
    3
    Location:
    Italy
    Worked also for me :)

    Thanks Deltafox!
     
  12. Brandon001

    Brandon001 Guest

    0
     
    Not working for me

    Not working for me

    Error: Some fields are empty or contain an improper value.

    and error area is Host name or IP address * which have value .\SQLEXPRESS

    :(:(:(
     
Loading...