• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Help, Unable to access Plesk

N

nberlanga

Guest
I get this error message whenever I go to the Plesk page on my server;

ERROR: PleskFatalException
Unable to connect to database: get_admin_password() failed: file_get_contents() failed:

0: /usr/local/psa/admin/plib/common_func.php3:174
psaerror(string 'Unable to connect to database: get_admin_password() failed: file_get_contents() failed: ')
1: /usr/local/psa/admin/auto_prepend/auth.php3:88

Any ideas? I can't make heads or tails of it.
 
Did you just update your MySQL server?

you never know, try running this command:
mysql_fix_privilege_tables --user=admin --password=`cat /etc/psa/.psa.shadow`
 
Originally posted by nberlanga
I get this error message whenever I go to the Plesk page on my server;

ERROR: PleskFatalException
Unable to connect to database: get_admin_password() failed: file_get_contents() failed:

Any ideas? I can't make heads or tails of it.

First of all try to check permissions on /etc/psa/.psa.shadow file:
# ls -la /etc/psa/.psa.shadow
-rw------- 1 psaadm psaadm 5 Дек 19 15:18 /etc/psa/.psa.shadow

After that try to connect directly to mysql? What results do you have?

# mysql -uadmin -p`cat /etc/psa/.psa.shadow

There can also be some permissions problem on mysql directories or something /var/lib/mysql/.
 
Hello,
I am a novice at this.

Happens to me the same.
I have read many posts on the forum, but I can not go into the Control Panel 9.x for linux plesk.

These are the errors I get:

ERROR: PleskFatalException
Unable to connect to database: get_admin_password() failed: file_get_contents() failed: mktime() [<a href='function.mktime'>function.mktime</a>]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead

0: common_func.php3:108
psaerror(string 'Unable to connect to database: get_admin_password() failed: file_get_contents() failed: mktime() [<a href='function.mktime'>function.mktime</a>]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead')
1: auth.php3:93

Intento:
#cat /etc/psa/.psa.shadow
cat: /etc/psa/.psa.shadow: No existe el fichero o el directorio

Any help? Very grateful in advance.
 
Hi UFHH01,

thank you very much for your help.
I have done the following:

edit the file /etc/php.ini
change

; date.timezone =

by

date.timezone = "Europe / Berlin"

Then I restarted apache: # service httpd restart

But it did not work, I still can not access the control panel Plesk 9.x for Linux, same error.
There's something I'm doing wrong?
thanks.
 
Hi Julen_Pinedo,

if your server is in the region "Europe / Berlin", then the correct setting in your php.ini - files would be:
PHP:
[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = "Europe/Berlin"

; http://php.net/date.default-latitude
date.default_latitude = 52.5194

; http://php.net/date.default-longitude
date.default_longitude = 13.4067

If your server is NOT located in the zone "Europe/Berlin", please try to find the correct zone.
You can find your php.ini - files with the help of this KB - article: http://kb.odin.com/1447 or use the command "locate php.ini"

Please adjust your settings according to your system settings, so that there is no difference ( if you need help with it, please specify your very own system, because the commands vary depending on your operating system ).

Please make sure to restart all webservers ( apache and possibly nginx? ) on your system and if used, FastCGI as well.
Keep in mind, that Plesk uses his very own webserver ( sw-cp-server ), which is independent from the one(s) on your system. The following KB - article will help you to find log and configuration files:

 
Back
Top