1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

high load average and very slow plesk loading...

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by saatchi, Mar 22, 2011.

  1. saatchi

    saatchi Basic Pleskian

    24
    57%
    Joined:
    Dec 17, 2005
    Messages:
    72
    Likes Received:
    0
    Hi,

    One of my servers has a problem in the last 3 weeks. Indeed, this problem is beginning after install a fresh PSA 10 and I couldn't solve it, yet! I have another server with the same structure and they haven’t this problem.

    Plesk 10.1.1, CentOS 5.5, Intel(R) Xeon(R) CPU - E5630 @ 2.53GHz

    Plesk panel loading is very slow and as you see in the attachments, Apache CPU usage and panel CPU usage is very high!
    Also when I get top report, you can see that load average is high. This is in change, constantly. Sometimes load average is more than 100 and just when I reboot the server, it will be good for less than 1 hour.
    Even, sometimes command typing is very slow and when I execute a command, it has problem to do.

    Could you please help me to find the problem? Let me know if you need any more information to solve it.
     

    Attached Files:

  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Any errors from logs?
     
  3. saatchi

    saatchi Basic Pleskian

    24
    57%
    Joined:
    Dec 17, 2005
    Messages:
    72
    Likes Received:
    0
    httpd error_log

    I get this lines (last 20):

     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Are you sure that server is not compromised? Try to check it with chkrootkit or with rkhunter
     
  5. Pedrosantos

    Pedrosantos Guest

    0
     
    Hi, i have the exact same problem , i ran the rhunter and nothing found, and this high loads as you described just started happening today....
    My Plesk Version is 10.0 and im in CENTOS 5.5
     
  6. saatchi

    saatchi Basic Pleskian

    24
    57%
    Joined:
    Dec 17, 2005
    Messages:
    72
    Likes Received:
    0
    I checked it with chkrootkit. everything is ok and I just get one infected alert:

    Checking `bindshell'... INFECTED (PORTS: 465)

    well, I think it's usual for Plesk, isn't it? so this problem is not from that!

    any other idea?
     
  7. saatchi

    saatchi Basic Pleskian

    24
    57%
    Joined:
    Dec 17, 2005
    Messages:
    72
    Likes Received:
    0
    Is there any way to monitor load average by processes?
     
  8. Pedrosantos

    Pedrosantos Guest

    0
     
    Any one that can help ?
     
  9. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Usually such problems require detailed and deep investigation directly on server. Real reasons can be found only after that. As you know there can be a lot of possible reasons. Therefore I suggest you contact support team if it is really important for you.
     
  10. Seyed AhmadS

    Seyed AhmadS Guest

    0
     
    hi,
    how can we install psa modules like rkhunter?
    is there any manual about that
     
  11. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    You should install psa-watchdog module which contains rkhunter.
     
  12. Seyed AhmadS

    Seyed AhmadS Guest

    0
     
    how to install psa-watchdog module.
    is it in yum repository or in plesk administrator module manager?
    is there any reference for this module for configuration?

    thanks for your help IgorG
     
  13. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Just run /usr/local/psa/admin/sbin/autoinstaller and select module for installation in menu.
     
  14. Seyed AhmadS

    Seyed AhmadS Guest

    0
     
    how about the manual?
     
  15. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    What do you mean?
     
  16. Seyed AhmadS

    Seyed AhmadS Guest

    0
     
    where can i find the manual about using & configuring the watchdog and the firewall of plesk
     
  17. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  18. Seyed AhmadS

    Seyed AhmadS Guest

    0
     
    this is plesk 10 documentation
    i'm using plesk 9.5.1 for my VPS's
     
  19. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  20. Seyed AhmadS

    Seyed AhmadS Guest

    0
     
    thanks for your help
     
Loading...