1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

High load on qmail - qmHandle is not helping

Discussion in 'Plesk for Linux - 8.x and Older' started by Filipe Miranda, Nov 22, 2007.

  1. Filipe Miranda

    Filipe Miranda Guest

    0
     
    Hello,

    I'm using qmHandle with Plesk 8.2, does anybody uses this software to control qmail queues?

    When I use the following command bellow I get an error:

    ./qmHandle -D
    Calling system script to terminate qmail...
    Can't exec "/usr/local/bin/svc": No such file or directory at ./qmHandle line
    192 (#1)
    (W exec) A system(), exec(), or piped open call could not execute the
    named program for the indicated reason. Typical reasons include: the
    permissions were wrong on the file, the file wasn't found in
    $ENV{PATH}, the executable in question was compiled for another
    architecture, or the #! line in a script points to an interpreter that
    can't be run for similar reasons. (Or maybe your system doesn't support
    #! at all.)

    If I use the .qmHandle -l I get this:
    Total messages: 573
    Messages with local recipients: 2
    Messages with remote recipients: 571
    Messages with bounces: 0
    Messages in preprocess: 0

    Also why do I have a high load of remote recipients?
    What does that mean?

    Any help is appreciated!!

    Thank you,
    Filipe Miranda
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    I just put out a new version yesterday, 1.3.2. Looks like the one you're using has the wrong paths internally.
     
  3. Filipe Miranda

    Filipe Miranda Guest

    0
     
    Hello,

    Thanks for the quick reply, but I'm using version qmhandle-1.3.2.
    Do you have the correct paths to use the in the qmHandle perl script file?

    Thank you,

    Regards,
    Filipe Miranda
     
  4. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Not off the top of my head, but probably /etc/init.d/qmail. The rpm sets that up at build time, so I never really looked into it.
     
  5. Filipe Miranda

    Filipe Miranda Guest

    0
     
    Another question...

    Messages with local recipients: 3
    Messages with remote recipients: 617
    Messages with bounces: 0
    Messages in preprocess: 0

    What does it mean local recipients: 3?
    Or remote recipients: 617 ?

    Should I be concerned with these numbers?

    Regards,
    Thank you,
    Filipe Miranda
     
  6. Filipe Miranda

    Filipe Miranda Guest

    0
     
    Hello, I found this directory: /var/qmail/bin

    But it does not have the svc binary...

    ...
     
  7. Filipe Miranda

    Filipe Miranda Guest

    0
     
    Hello,

    I got your version of the qmHandle and it also has the wrong paths inside the Perl script....
     
  8. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    should be fixed in the latest update, 1.3.2-2
     
  9. Filipe Miranda

    Filipe Miranda Guest

    0
     
    Could you please post the URL to get the latest update?

    Thank you,

    Regards,
    Filipe Miranda
     
  10. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    There are 14 URL's, depending on the distribution and the architecture. Best way to get it is via yum.
     
  11. Filipe Miranda

    Filipe Miranda Guest

    0
     
    Could you please post the one for the RHEL5 ?

    Thank you,
     
  12. Filipe Miranda

    Filipe Miranda Guest

    0
     
  13. Filipe Miranda

    Filipe Miranda Guest

    0
     
  14. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Heh, you know you could just type "yum update" right?
     
  15. Filipe Miranda

    Filipe Miranda Guest

    0
     
    Oh, yeah I know how to use yum, but the fact is, I di not setup my yum to get the RPMs from your URL...

    Since I just wanted to get the qmhandle software, I just downloaded it and installed it.

    Thank you again,

    Regards,
    Filipe Miranda
     
  16. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
  17. ARUNP

    ARUNP Guest

    0
     
    A small update to first post..
    please try running the command after stopping qmail..
     
  18. savesheep

    savesheep New Pleskian

    6
     
    Joined:
    Oct 14, 2013
    Messages:
    4
    Likes Received:
    0
    I seriously hate bringing up old threads but I can't find anything else on the internet that has to do with this.

    I get the exact same error as stated above on plesk using qmHandle 1.3.2 but there is no update anywhere in regards to 2-2 as stated above. Can someone help point me in the right direction so I can use this?

    Also - yum update says there is no package for smeserver-qmHandle or qmHandle.

    Thanks so much for the help!
     
  19. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    You have the repo set up right? The latest build is 1.3.2-4 now
     
  20. savesheep

    savesheep New Pleskian

    6
     
    Joined:
    Oct 14, 2013
    Messages:
    4
    Likes Received:
    0
    I must not have the repo set up at all. it's a MediaTemple DV server that came with qmHandle installed so it wasn't set up by yum in the first place. I'm rather new to this, is there an easy way to set it up so I can use yum to update it? Thanks!

     
Loading...