1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Holly **** I Think I Figured Out The Perl Problem

Discussion in 'Plesk for Linux - 8.x and Older' started by tecdady, May 30, 2005.

  1. tecdady

    tecdady Guest

    0
     
    this is unreal. i looked into the httpd.include file in the conf directory of one of my virtual domains. this is what was included for the execution of perl files in the httpd.include:

    <Directory /home/httpd/vhosts/final9sports.com/httpdocs>
    <IfModule mod_perl.c>
    <Files ~ (\.pl$)>
    SetHandler perl-script
    PerlHandler ModPerl::Registry
    Options ExecCGI
    allow from all
    PerlSendHeader On
    </Files>


    Anyone see a massive problem here?
    <Directory /home/httpd/vhosts/final9sports.com/httpdocs>

    eh... hmm. httpdocs? i changed the to cgi-bin. all scripts ran IMMEDIATELY. you have got to be kidding me. could this REALLY be the problem? this is on a psa 7.5.3 box. now im scared after reading that plesk overwrites these files, this will get changed back and everything will break again. can someone shed some light on this and let me know what ive found. and that if it is THE problem, where to fix a "master" conf file so that this wont get overwritten with the incorrect file location. and finally, CAN SWSOFT REALLY BE THIS F*CKING STUPID?
     
  2. Artur

    Artur Guest

    0
     
    This is INCREDIBLE we have the same problem after rewriting a client's httpd.include in his conf directory. Well done swsoft, well done!
     
Loading...