1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Horde 3.0 Webmail need conf.php file

Discussion in 'Plesk for Linux - 8.x and Older' started by peterson40, May 17, 2005.

  1. peterson40

    peterson40 Guest

    0
     
    Hello,

    I accidentally wrote over the "conf.php" file in

    /usr/share/psa-horde/config/

    I was wondering if someone could send that to me at petersont@northpark.edu or repond to this below.

    my webmail does not work now that I wrote over the conf.php file

    Thanks!
     
  2. editor

    editor Guest

    0
     
    Your description cannot be true. A "conf.php" has never existed.

    psa-horde does not exist in /usr/share/psa-horde/
    this is why you also cannot find the /usr/share/psa-horde/config/

    Correct is:

    /home/httpd/vhosts/webmail/horde
    /home/httpd/vhosts/webmail/horde/templates/horde

    And if you look for the "/config/"-folder of horde, then you will find it
    in

    /home/httpd/vhosts/webmail/horde/config/

    and there are these files in it:

    -r--r--r-- 1 root root 13531 Apr 21 05:29 horde.php
    -r--r--r-- 1 root root 13531 Jan 27 22:32 horde.php.dist
    -r--r--r-- 1 root root 13200 Jan 27 22:32 horde.php.dist.orig
    -r--r--r-- 1 root root 5724 Apr 21 05:29 html.php
    -r--r--r-- 1 root root 5724 Jan 27 22:32 html.php.dist
    -r--r--r-- 1 root root 22045 Apr 21 05:29 lang.php
    -r--r--r-- 1 root root 22045 Jan 27 22:32 lang.php.dist
    -r--r--r-- 1 root root 9393 Apr 21 05:29 mime_drivers.php
    -r--r--r-- 1 root root 9393 Jan 27 22:32 mime_drivers.php.dist
    -r--r--r-- 1 root root 6685 Apr 21 05:29 mime_mapping.php
    -r--r--r-- 1 root root 6685 Jan 27 22:32 mime_mapping.php.dist
    -r--r--r-- 1 root root 140 Apr 21 05:29 motd.php
    -r--r--r-- 1 root root 140 Jan 27 22:32 motd.php.dist
    -r--r--r-- 1 root root 2282 Apr 21 05:29 prefs.php
    -r--r--r-- 1 root root 2282 Jan 27 22:32 prefs.php.dist
    -r--r--r-- 1 root root 12590 Apr 21 05:29 registry.php
    -r--r--r-- 1 root root 12590 Jan 27 22:32 registry.php.dist
    -r--r--r-- 1 root root 12592 Jan 27 22:32 registry.php.dist.orig

    Note: horde.php, horde.php.dist are the config-Files of Horde.

    --------cut--------horde.php---------------
    <?php
    /*
    * Horde Configuration File
    *
    * This file contains global configuration settings for Horde. Values may be
    * safely edited by hand. Use horde.php.dist as a reference.
    *
    * Default user preferences are defined in 'prefs.php'.
    *
    * Strings should be enclosed in 'quotes'.
    * Integers should be given literally (without quotes).
    * Boolean values may be 'true' or 'false'.
    *
    * $Horde: horde/config/horde.php.dist,v 1.47.2.36 2003/10/14 16:52:31 slusarz Exp $
    */

    /**
    ** General Horde Settings
    **/

    // The value to set.....
    --------cut--------horde.php---------------
     
  3. rtwick

    rtwick Basic Pleskian

    23
     
    Joined:
    Nov 1, 2002
    Messages:
    33
    Likes Received:
    0
    Code:
    ls /usr/share/psa-horde/config
    conf.php  mime_drivers.php  nls.php    registry.d
    conf.xml  motd.php          prefs.php  registry.php
    
    it exists in 7.5.3

    peterson .. sent you the file
     
  4. editor

    editor Guest

    0
     
    you see by yourself that this cannot work and whatta bug this is.

    Plesk 7.5.2
    /home/httpd/vhosts/webmail/horde/

    Plesk 7.5.3
    /usr/share/psa-horde/

    Does it anyone wonder why webmail cannot work anymore?
    Making an update with the auto-installer of Plesk/SW-Soft is
    the same like to hack your running webmail.
     
  5. mvnnet

    mvnnet Guest

    0
     
    I just ran into the same problem.

    In 7.5.2, the Horde web site was in /home/httpd/vhosts/webmail/. Now, it's in /usr/share/psa-horde/ and the configurations seem to be completely gone.

    As a special bonus, the auto-upgrade process seems to have confused rpm on my Fedora Core 2 system:

    Code:
    [root@webpanel p]# rpm -e psa-horde-3.0.4-fc2.build75050506.13.noarch.rpm
    error: package psa-horde-3.0.4-fc2.build75050506.13.noarch.rpm is not installed
    [root@webpanel p]# rpm --install psa-horde-3.0.4-fc2.build75050506.13.noarch.rpm
            package psa-horde-3.0.4-fc2.build75050506.13 is already installed
    
    The file is there, but seems to be missing some of its parts. Visiting a webmail.valid.domain (one that had Webmail installed) yields this:

    A fatal error has occurred
    Required 'Array' not specified in DataTree SQL configuration. The file /config/conf.php should contain a $conf['storage']['params']['Array'] setting.

    (followed by a few characters in what looks to be Hebrew)

    Any suggestions on a fix or workaround?
     
  6. aedwards

    aedwards Guest

    0
     
    ditto on the error message. I thought the last text was arabic, but either way it is not cool. Unfortunately I do not hav ea lot of data as I went from 7 on one server straight to 7.5.3 on another server. Never worked.

    Anyone?
     
  7. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    RedHat 9 with PSA 7.5.3 has the conf.php file in

    /etc/psa-horde/horde/conf.php

    What OS are you using?
     
  8. aedwards

    aedwards Guest

    0
     
    RH9, bit I did resolve the problem by using another article. I had to REM out the ioncube portion of horde. What the heck does it do anyways?

    I am a novice linux user. You should have seen the sweat that I pored just trying to figure out how to use this state of the art server with Plesk. I had to create a matrix of hardware and software compatibility and ended up on RH9 with 1 driver I had to compile myself (rrom detail instruction written by someone smarter than me).

    Thank for asking though.
     
  9. sparkybarkalot

    sparkybarkalot Guest

    0
     
    I had this the problem mentioned below:

    A fatal error has occurred
    Required 'Array' not specified in DataTree SQL configuration. The file /config/conf.php should contain a $conf['storage']['params']['Array'] setting.

    (followed by a few characters in what looks to be Hebrew)

    and used aedwards solution of REMing out the ioncube portion of horde, which also worked for me. The "another article" that aedwards mentions which solved the problem can be found here:

    http://forum.sw-soft.com/showthread.php?threadid=20313&highlight=ioncube+horde

    mac0310's post is the relevant post.
     
  10. hazzah

    hazzah Guest

    0
     
    Hi everbody. I am resurrecting this thread.

    Using 1and1 fedora hosting and upgraded my plesk. Of course I get the message:

    "Required 'Array' not specified in DataTree SQL configuration. The file /config/conf.php should contain a $conf['storage']['params']['Array'] setting.
    "

    Now I looked at the config files. First seems I have two:

    /etc/psa-horde/conf.php
    and
    /usr/share/psa-horde/config/conf.php

    I can find no reference to "ioncube" anywhere. Can anybody help me with this? Perhaps the solution is unlcear. I have checked the other threads on this and still cannot make sense of what is required.

    Regards, Pieter
    Budapest
     
  11. hazzah

    hazzah Guest

    0
     
    As is often the case... the sheer panic of the situation and the desparation in consulting the forum means that I solved the problem (after a day of sweat.)

    I did manage to find the /etc/php.d/ioncube.ini file and comment out the zend line...

    And hey presto!!! it works...

    Anyway hopefully by adding this to the thread will help others in the future...

    Regards, Pieter
    Budapest
     
Loading...