1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How Do I Block Email From All Except Localhost?

Discussion in 'Plesk for Linux - 8.x and Older' started by Superman859, Apr 25, 2008.

  1. Superman859

    Superman859 Guest

    0
     
    I have one email address set up for a domain that I would like to only accept localhost mail on. It receives some spam, and I only use it for administrative purposes of the domain and personal notifications of events that occur, so there is no need for that email address to even receive mail from other mail servers.

    Is this possible to configure in Plesk?
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Sure you can do it with firewall rules. Either disable the smtp one from the firewall policy manage in plesk, or if you want to do it from the command line:


    iptables -I INPUT -i eth0 -p tcp --dport 25 -j DROP
     
  3. Superman859

    Superman859 Guest

    0
     
    Well, that certainly would block email from other mail servers. However, I have lots of email addresses that I would like to continue receiving email from other servers. There are several domains on the server, and several email addresses with each domain. There is only one email address associated with a specific domain that I want to block incoming email on. I would like to be able to only allow incoming mail from whitelisted addresses for that one email address, while leaving the other addresses unaffected.
     
  4. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Have you tried using the blacklist on that one?
     
Loading...