1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How to disable Safe mod on a subdomain ?

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by LaurentR2D2, Feb 27, 2011.

  1. LaurentR2D2

    LaurentR2D2 Plesk Certified Professional Plesk Certified Professional

    31
    68%
    Joined:
    Aug 6, 2009
    Messages:
    129
    Likes Received:
    4
    Hello,

    I have a domain on which Safe mod is disabled (it's unchecked, so I guess it's disabled :)). I've created a subdomain to install Dolphin (http://www.boonex.com/dolphin/). This software won't install if Safe mod is on. Safe mod is on on this subdomain when it's off on the domain. How can I disable safe mod on the subdomain ?

    Thank you
     
  2. LaurentR2D2

    LaurentR2D2 Plesk Certified Professional Plesk Certified Professional

    31
    68%
    Joined:
    Aug 6, 2009
    Messages:
    129
    Likes Received:
    4
    I've tried to disable safe mod in php.ini and it doesn't change. Php is used with Fast CGI
     
  3. Farsus

    Farsus Basic Pleskian

    23
     
    Joined:
    Sep 1, 2005
    Messages:
    44
    Likes Received:
    0
  4. LaurentR2D2

    LaurentR2D2 Plesk Certified Professional Plesk Certified Professional

    31
    68%
    Joined:
    Aug 6, 2009
    Messages:
    129
    Likes Received:
    4
    I have tried solution 2 without success. I always have the install program which says Safe mod is on :

    http://dolphin.madonie.org/install/index.php

    Concerning Solution 1, I haven't tried it since it is written as being compatible with Plesk 9.x and I have Plesk 10.x

    Thank you
     
  5. LaurentR2D2

    LaurentR2D2 Plesk Certified Professional Plesk Certified Professional

    31
    68%
    Joined:
    Aug 6, 2009
    Messages:
    129
    Likes Received:
    4
    I've tried another time today. I've put "safe_mode = Off" in a php.ini file which I've put in the conf folder of the domain and restarted apache. safe_mod is still on. The patch in the kb above seems interesting, but it works for version 9 and not version 10. I've put the full pho.ini file in the conf folder, without success. It's a little boring. I'm trying to install Dolphin (http://www.boonex.com) and install won't work with safe_mod on.
     
Loading...