How to Redirect HTTPS to HTTP

Discussion in 'Plesk 11.x for Linux' started by Upgrade, Jul 18, 2014.

  1. Upgrade

    Upgrade New Pleskian

    6
    20%
    Joined:
    Feb 7, 2014
    Messages:
    4
    Likes Received:
    0
    HELLO ALL!

    how can I make a redirect traffic to the site that I have over HTTPS in HTTP?

    Disabling SSL 404
    Using Plesk 11 with nginx + php-pfm

    Thank you
     
  2. iServersupport

    iServersupport New Pleskian

    9
     
    Joined:
    Nov 20, 2013
    Messages:
    24
    Likes Received:
    2
    You can do that by creating a htaccess rule

    RewriteEngine on
    RewriteCond %{SERVER_PORT} ^443$
    RewriteRule ^(.*)$ http://www.iserversupport.com/$1 [R=301,L]

    Make sure to replace iserversupport.com with your domain name
     
    Last edited: Jul 19, 2014
  3. Upgrade

    Upgrade New Pleskian

    6
    20%
    Joined:
    Feb 7, 2014
    Messages:
    4
    Likes Received:
    0
    Thank you but HTACCESS does not work if I use plesk with nginx + php-fpm

    How can I do it with my environment?
    you can do this for all vhosts / domains configured in plesk 11.5?
     
  4. TehranShop

    TehranShop New Pleskian

    1
     
    Joined:
    Wednesday
    Messages:
    1
    Likes Received:
    0
    Location:
    TEHRAN
    Hi everybody
    I have same Problem with my site
    I want to load it with HTTP Protocol and don't load with HTTPS
    and i try anything with "hosting settings" and
    SSL/TLS Certificates
    remove it but load it again and again
    push this codes to .htzccess file and load it again to HTTPS

    RewriteEngine on
    RewriteCond %{SERVER_PORT} ^443$
    RewriteRule ^(.*)$ http://2tehrankbs.org/$1 [R=301,L]


    please help me how to redirect the HTTPS to HTTP
    I have plesk onyx 17.5.3

    Thanks
     
  5. UFHH01

    UFHH01 Platinum Pleskian Plesk Guru

    40
    64%
    Joined:
    Jun 11, 2013
    Messages:
    4,905
    Likes Received:
    1,014
    Location:
    Hamburg / Germany
    Hi TehranShop,

    yout site ( actually ) loads over HTTP, so pls. consider to delete YOUR cache and YOUR temporary internet files on your very own computer to solve issues as described.
     
Loading...