1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How to Update php ( Centos 5 - plesk 10.1 )

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by steffann, May 18, 2011.

  1. steffann

    steffann Guest

    0
     
    Hey guys.

    having big issues updating my php from the standard php given from plesk 10.1. is there a way to do this through plesk ?

    Currently trying this through SSH and having little luck .


    [root@ns351676 ~]# yum update php
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * atomic: www7.atomicorp.com
    Excluding Packages in global exclude list
    Finished
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    --> Processing Dependency: php <= 5.2.0 for package: php-sqlite2
    ---> Package php.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: php-cli = 5.3.6-3.el5.art for package: php
    --> Processing Dependency: php-common = 5.3.6-3.el5.art for package: php
    --> Running transaction check
    ---> Package php-cli.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: libedit.so.0()(64bit) for package: php-cli
    --> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-pdo
    --> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-mbstri ng
    --> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-gd
    --> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-mysql
    --> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-soap
    --> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-xml
    --> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-imap
    ---> Package php-common.x86_64 0:5.3.6-3.el5.art set to be updated
    ---> Package php-sqlite.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: any-php-sqlite2 for package: sb-publish
    --> Running transaction check
    ---> Package libedit.x86_64 0:20090923-3.0_1.el5.rf set to be updated
    ---> Package php-gd.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: libt1.so.5()(64bit) for package: php-gd
    ---> Package php-imap.x86_64 0:5.3.6-3.el5.art set to be updated
    ---> Package php-mbstring.x86_64 0:5.3.6-3.el5.art set to be updated
    ---> Package php-mysql.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for pa ckage: php-mysql
    --> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql
    ---> Package php-pdo.x86_64 0:5.3.6-3.el5.art set to be updated
    ---> Package php-soap.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: any-php-sqlite2 for package: sb-publish
    ---> Package php-xml.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Running transaction check
    ---> Package mysql-libs.x86_64 0:5.1.57-1.el5.art set to be updated
    --> Processing Dependency: any-php-sqlite2 for package: sb-publish
    ---> Package t1lib.x86_64 0:5.1.2-2.el5.art set to be updated
    --> Processing Dependency: libXaw.so.7()(64bit) for package: t1lib
    --> Processing Dependency: libXt.so.6()(64bit) for package: t1lib
    --> Running transaction check
    ---> Package libXaw.x86_64 0:1.0.2-8.1 set to be updated
    --> Processing Dependency: libXmu.so.6()(64bit) for package: libXaw
    ---> Package libXt.x86_64 0:1.0.2-3.2.el5 set to be updated
    --> Processing Dependency: libSM.so.6()(64bit) for package: libXt
    --> Processing Dependency: any-php-sqlite2 for package: sb-publish
    --> Running transaction check
    ---> Package libSM.x86_64 0:1.0.1-3.1 set to be updated
    ---> Package libXmu.x86_64 0:1.0.2-5 set to be updated
    --> Processing Dependency: any-php-sqlite2 for package: sb-publish
    --> Finished Dependency Resolution
    sb-publish-3.0.1-200705230938.noarch from installed has depsolving problems
    --> Missing Dependency: any-php-sqlite2 is needed by package sb-publish-3.0.1-200705230938.noarch (installed)
    Error: Missing Dependency: any-php-sqlite2 is needed by package sb-publish-3.0.1-200705230938.noarch (installed)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.
    [root@ns351676 ~]# yum update sqlite2
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * atomic: www7.atomicorp.com
    Excluding Packages in global exclude list
    Finished
    Setting up Update Process
    No Packages marked for Update
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
  3. atomicrocketturtle

    atomicrocketturtle Guest

    0
     
    Id also add that its always a good idea to report these directly on the atomic forums, I don't have the time to check the plesk forums as frequently as I used to.
     
  4. SangD

    SangD Guest

    0
     
  5. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    I think you should write YES there and then push ENTER button.
     
  6. SangD

    SangD Guest

    0
     
    Need help

    I worked..But Php still 5.1.6

    [root@u15796955 ~]# php -v
    PHP 5.1.6 (cli) (built: Nov 29 2010 16:47:46)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    with the ionCube PHP Loader v3.1.28, Copyright (c) 2002-2007, by ionCube Ltd


    I think may be Centos 5 with Flesk 10.. we can't update this way!

    ? thank..and like hear your voice!
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    You can install PHP53 via Plesk autoinstaller. Just run /usr/local/psa/admin/sbin/autoinstaller anf select PHP53 in menu for installation.
     
  8. MishterAnderson

    MishterAnderson Guest

    0
     
    I was trying to upgrade my php as well using this, but when I go into autoinstaller, it only shows PHP5 support as a menu option, and if I go into that, it says it's already installed.

    The other menu options don't have anything about php them from what I could see.

    I would use the atomiccorp thing, but I want to keep using proftp.
     
  9. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Selecting PHP53 for installation via autoinstaller is available only for Redhat based OSes. If you have ubuntu, debian or suse - use official OS vendor's repositories for PHP updating.
     
  10. Mike Aushana

    Mike Aushana Guest

    0
     
    Sorry to jump in this thread but I'm looking to do the same thing and wanted to know if IgorG's instructions worked? Also, if I need to revert back my PHP version in case of any issues with my client's code is there a way to do this when using Plesk 10.2.0 with Linux 2.6.18-194.26.1.el5xen. Any help is appreciated.

    Thank you,

    Mike
     
  11. Mike Aushana

    Mike Aushana Guest

    0
     
    I think I did this correctly. I was able to upgrade to PHP 5.3.3 using the Plesk panel. I did the following:

    1) Login as super user to the panel
    2) Under the Server Management > Tools & Utilities > Panel click "Updates"
    3) Once the screen loads click "Add Product Components"
    4) In the list of components make sure you have "Different PHP interpreter versions" checked
    5) Just below "Different PHP.." you should have the option of PHP5.3 support. This might not be there until you configure the "Different PHP..." option. If it's not there check the "Different PHP..." and come back and repeat the steps above to see the PHP5.3 option.
    6) Select PHP5.3 support and click continue to install and configure it on your plesk server

    That's all I had to do and it seems to be working so far. The only thing I had to do was disable "safe_mode" in my php.ini file which is located here /etc/php.ini as this is now deprecated in the new PHP versions. I hope that helps.

    Mike
     
    Last edited by a moderator: Sep 19, 2011
Loading...