1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

How to upgrade PHP 4.3.2 to 5.0.3 to patch vulnerabilites?

Discussion in 'Plesk for Linux - 8.x and Older' started by hprod, Jan 24, 2005.

  1. hprod

    hprod Guest

    0
     
    Due to the recent discovered high risk vulnerabilities at PHP 4.3.2, or earlier we would like to upgrade to 5.03.
    Is there an automatic way of doing it at plesk?
    I cant find the option at UPGRADE options.
    Maybe with up2date?

    If I do it manually, will I damage Plesk control panel?

    Thanks in advance
     
  2. alex042

    alex042 Guest

    0
     
    If you are using RHE and all you're worried about is security patches, I'd stick with 4.3.2 that comes with it because Redhat has been backporting security patches to 4.3.2 and up2date should automatically update your copy of php with these patches. If you upgrade to 5.0, you'll need to constantly maintain these patches yourself.
     
  3. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    php 5 definitely breaks a lot of apps, specifically webmail (horde and squirrelmail). I've got php 4.3.10 and php 5.0.x rpms available in my yum archive (rh9, 3es, fc1/2/3).
     
  4. rthrash@

    rthrash@ Guest

    0
     
    Now that Horde 3/IMP 4 is now out, any chance webmail might get back to working again with PHP 5.0.x?
     
  5. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    I tried it with that (and the latest squirrelmail) , but it still didnt work. Im still looking into it, its possible that its something in the way Im building php, or perhaps one of the libraries Im linking to
     
Loading...