• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

.htaccess problem

W

Waylander

Guest
hello,

ive a problem with secured directorys now,
when i protect a dir via plesk (even via webmin) the site is secured, but no prompt show up to enter my user/pass

i just see:

Authorization Required

This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

this occurs on firefox and iexplorer
:confused:

every hint is welcome :)

sorry for my bad english, thanks

way
 
Check the errorlog for that domain, it might give you an indication on the issue.
 
oh yes, ive checked all logs but the "domainlogs" :) this show me:

File does not exist: /home/httpd/vhosts/domain.info/error_docs/unauthorized.html

so i disabled the user errordocs in domain-setup und voila, the loginscreen show up. strange, but it works now. thanks hardweb!

way
 
It's not strange - it's perfectly normal behavior in Apache:

If the unauthorized.html file is not found when enabling custom errordocs, Apache throws an error header and not the "Basic Realm Auth" header.

So if you want to use custom errordocs, just make sure the errordocs exists :eek:)

--
//Geert
 
Back
Top