1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

httpd.include contains wrong data

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by iChain, Oct 15, 2012.

  1. iChain

    iChain New Pleskian

    10
     
    Joined:
    Oct 15, 2012
    Messages:
    1
    Likes Received:
    0
    Hi Everyone,
    I am using 10.4.4 Plesk (Update #32). By a mistake I've deleted one of my domains (sample.com) with all it's subdomains. In order to restore it I've done the following:
    - I've create a new domain with the same domain name at plesk (sample.com)
    - I've tried to restore it via domain's Backup Manager (I've got some backups of it). The restoring process haven't passed well - I've got some warnings like "Plesk wasn't able to restore the domain 1%: name "sample.com" is already used in Panel domain ". After that all domain's structure and databases were restored, but some of the data that was in the domain's folder was missing.
    - My final step was restoring all missing data from the server backup from my hoster. I've replaced the domain's folder with the one from the backup.

    After these manipulations everything worked just fine, until Plesk hasn't overwritten it's configuration. So here is the problem - httpd.include file for the "sample.com" domain contains the wrong domain name. There is another domain name (this domain wasn't influenced by these actions) listed in this file instead of the "sample.com"

    Here is one of the wrong strings from httpd.include:
    DocumentRoot "/var/www/vhosts/wrong_domain.com/httpdocs
    and it should be
    DocumentRoot "/var/www/vhosts/sample.com/httpdocs

    Same is for all "sample.com" subdomains. I've tried to edit httpd.include manually, and everything works just fine if I'll correct all wrong domain names to the proper ones, but Plesk overwrites this file after any changes. So I always get everything back...

    Maybe there is some permanent way to edit this file? Or I've done something wrong?
    I'll appreciate any advice from your side (however I'd prefer not to delete this domain one more time).

    Thank you in advance!
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Running below should rebuild ALL vhost configuration files for that domain name ..
    /usr/local/psa/admin/sbin/httpdmng --reconfigure-domain [yourdomain.com]
     
  3. IlavarasiS

    IlavarasiS New Pleskian

    10
     
    Joined:
    Nov 5, 2012
    Messages:
    1
    Likes Received:
    0
    creating virtual host

    Hi,

    Can you please help me, I am new to create virtual host

    I am trying to create virtual host,

    my entry in vhost.conf is


    DocumentRoot /var/www/vhosts/testing.xxx.co.nz/httpdocs/web

    <Directory /var/www/vhosts/testing.xxx.co.nz/httpdocs/web >
    AllowOverride all
    Order allow,deny
    Allow from all
    </Directory>




    I run the command

    /usr/local/psa/admin/bin/httpdmng --reconfigure-domain testing.xxx.co.nz

    and restarted the apache by,

    apache2ctl restart


    but I get HTTP Error 500 when I try to access http://testing.xxx.co.nz



    Is it the right way to create virual host?

    I have many autogenerated *httpd.include files in the /var/www/vhosts/testing.xxx.co.nz/conf folder...

    where can I find the httpd.conf file to check whether my vhost.conf is included or not?



    Thanks in advance

    -Ila
     
    Last edited: Nov 5, 2012
Loading...