1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

httpd start problem

Discussion in 'Plesk for Linux - 8.x and Older' started by NightStorm, Feb 2, 2005.

  1. NightStorm

    NightStorm Guest

    0
     
    My httpd was running fine with 7.5.1... tried the upgrade to 7.5.2, and now httpd will not start.
    Returns the error:
    Starting httpd: httpd: bad user name USER
    Can't find any documentation for this anywhere... any ideas what I might be looking for?
    System is RHES3
    httpd version: 2.0.46-44.ent.WB1
     
  2. JLChafardet

    JLChafardet Regular Pleskian

    26
    57%
    Joined:
    Feb 20, 2004
    Messages:
    379
    Likes Received:
    0
    Location:
    Caracas - Venezuela
    I was having the same problem, no httpd starts.

    i went to php.ini, commented the ioncube loader line.

    tryed to start httpd, no luck.

    then i noticed that in
    "/etc/php.d" is a file called "ioncube.ini"

    i decided to try, commented that line inside of it. saved and exit the file, and restarted apache, it did start.

    as i wanted the ioncube to load, i went again to php.ini, removed the comment from the ioncube loader line(it should be at the whole top of the zend section), saved and exit the file (php.ini)

    and restarted apache "service httpd restart" and it started wonderfully.

    hope this helps you,

    best regards,
     
  3. NightStorm

    NightStorm Guest

    0
     
    My zend section on php.ini:
    [Zend]
    zend_optimizer.optimization_level=15
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-2.5.7
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-2.5.7
    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

    So I don't even have mention of ioncube. Am I supposed to?
    This wasn't a problem with 7.5.2, so what did they change?

    My directory structure for /etc/php.d is:

    imap.ini ldap.ini mbstring.ini mcrypt.ini mhash.ini mysql.ini odbc.ini pgsql.ini snmp.ini xmlrpc.ini
     
  4. NightStorm

    NightStorm Guest

    0
     
    I managed to get httpd to start by creating the user USER with the ame permissions and flags as apache... but I want someone from Plesk to tell me what the Hell I just had to do, and why.
    What has changed that suddenly required the user "USER", and why did the install not create it automatically?
     
  5. nibb@

    nibb@ Guest

    0
     
    Well i had a user that his domains did not worked with www. but did without, so i looked into his /conf/httpd.conf file and it seem it something was wrong there, it complained, so i copied a httpd.conf from a working directory and replaced the domain so it works with the current one. Now apache says the same thing.
    httpd: httpd: bad user USER

    How can i fix this?
     
  6. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    thank you SW-Soft for making a Knowledgebase article about this:

    http://kb.swsoft.com/article_41_1520_en.html

    The complexity is php.ini does not include the ioncube directive on my Fedora Core 6 box, instead it's included by way of php.d in another folder. I renamed that file (because it had only the ioncube line) and moved the text into php.ini above the Zend code...
     
Loading...