1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

IMP and Proftpd config proposal

Discussion in 'Plesk for Linux - 8.x and Older' started by BoXie, May 10, 2005.

  1. BoXie

    BoXie Guest

    0
     
    I think SW-Soft should enable the following settings by default in /etc/psa-horde/imp/conf.php

    Code:
    $conf['mailbox']['show_attachments'] = true;
    $conf['mailbox']['show_preview'] = true;
    $conf['mailbox']['show_xpriority'] = true;
    
    And perhaps also add these ones in /etc/proftpd.conf:

    Code:
    TimeoutIdle                     900
    TimeoutNoTransfer        900
    PassivePorts                    49152 65534
    TimesGMT                        Off
    
    The PassivePorts directive can be pretty usefull when you have a firewall enabled on the server. But i'm still waiting for Plesk to add a feature to work with port-ranges in the firewall module .. instead of single port lists.
     
  2. GARMTECH

    GARMTECH Guest

    0
     
    $conf['mailbox']['show_attachments'] really loads server (it must open every email in mailbox to see it there attachment inside or not). If a lot of your customers use webmail it will be a problem. I think the same problem with other two options, but not too huge as attachment.
     
  3. BoXie

    BoXie Guest

    0
     
    Are you really sure ? Is that knowledge based on facts or just a wild guess?

    I mean .. even for the subject to appear the system has to open the mail or not?
     
  4. Jason Lee

    Jason Lee Guest

    0
     
    They might also want to change the following in /etc/psa-horde/imp/conf.php
    Code:
    $conf['spam']['reporting'] = true;
    $conf['notspam']['reporting'] = true;
    and in /etc/proftpd.conf
    Code:
    DenyFilter \*.*/
    The DenyFilter will help to prevent a serious problem that would make Proftpd consume all the memory on the server when it receives a certain command. But that is only part of the solution. The other half is to upgrade proftpd to 1.2.2
     
Loading...