1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

index.php not loading on some domains.

Discussion in 'Plesk for Linux - 8.x and Older' started by dennysp, Dec 26, 2004.

  1. dennysp

    dennysp Guest

    0
     
    Hi,
    I just installed 7.5.1 and I notice that some domains only display the contect of any .php file instead of actually running it. This only happens in a couple of domains. I don't see vhost.conf file or anything different in the configuration. Can someone please advice on what could be the problem?

    Thanks
    -d
     
  2. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    965
    Likes Received:
    32
    Location:
    Romania
    This problem seems to be in short tag problem, probbbly is off in php.ini.
    This is happening when you use in php files like this.

    <?php - this is the correct sentence
    nd you have
    <? - this is wrong. put in all php file lik I mentioned and will work.
     
  3. Master Ruthless

    Master Ruthless Guest

    0
     
    Try turning display_errors on in your php.ini.
    This should give you a clue as to whats going on.

    I would turn it off afterwards being it really makes a mess of sites which are coded sloppily :p
     
  4. Cranky

    Cranky Guest

    0
     
    Do you have PHP enabled for these domains in Plesk? Try copying one of the scripts which don't work to a domain which you think does work to see if it's server config or domain config not working.
     
Loading...