1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

install mycrypt fail

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Detachable, Aug 2, 2011.

  1. Detachable

    Detachable Guest

    0
     
    I'm just not getting why this isnt working exactly...I upgraded php from 5.x to 5.3 using plesk's upgrade function but suprised it didn't have mcrypt already, but how do i now get it to install? I did search first but nothing matches my exact problem here **


    Installed Packages
    php5-ioncube-loader.x86_64 4.0.7-11030112 installed
    php53.x86_64 5.3.3-1.el5_6.1 installed
    php53-cli.x86_64 5.3.3-1.el5_6.1 installed
    php53-common.x86_64 5.3.3-1.el5_6.1 installed
    php53-gd.x86_64 5.3.3-1.el5_6.1 installed
    php53-imap.x86_64 5.3.3-1.el5_6.1 installed
    php53-mbstring.x86_64 5.3.3-1.el5_6.1 installed
    php53-mysql.x86_64 5.3.3-1.el5_6.1 installed
    php53-pdo.x86_64 5.3.3-1.el5_6.1 installed
    php53-sqlite2.x86_64 5.3.2-11011812 installed
    php53-xml.x86_64 5.3.3-1.el5_6.1 installed


    **HERE

    [poot@RMD-C etc]# yum install php-mcrypt.x86_64
    Loaded plugins: rhnplugin, security
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package php-mcrypt.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: php-common = 5.3.6-3.el5.art for package: php-mcrypt
    --> Running transaction check
    ---> Package php-common.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53
    --> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53-xml
    --> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53-mbstring
    --> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53-imap
    --> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53-cli
    --> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53-gd
    --> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53-pdo
    --> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53-mysql
    --> Running transaction check
    ---> Package php.x86_64 0:5.3.6-3.el5.art set to be updated
    ---> Package php-cli.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: libedit.so.0()(64bit) for package: php-cli
    ---> Package php-gd.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: libt1.so.5()(64bit) for package: php-gd
    ---> Package php-imap.x86_64 0:5.3.6-3.el5.art set to be updated
    ---> Package php-mbstring.x86_64 0:5.3.6-3.el5.art set to be updated
    ---> Package php-mysql.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: php-mysql
    --> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql
    ---> Package php-pdo.x86_64 0:5.3.6-3.el5.art set to be updated
    ---> Package php-xml.x86_64 0:5.3.6-3.el5.art set to be updated
    --> Processing Dependency: php53 >= 5.3.0 for package: php53-sqlite2
    --> Processing Dependency: php53 for package: psa-php53-configurator
    --> Processing Dependency: php53-cli for package: psa-php53-configurator
    --> Processing Dependency: php53-gd for package: psa-php53-configurator
    --> Processing Dependency: php53-imap for package: psa-php53-configurator
    --> Processing Dependency: php53-mbstring for package: psa-php53-configurator
    --> Processing Dependency: php53-mysql for package: psa-php53-configurator
    --> Processing Dependency: php53-pdo for package: psa-php53-configurator
    --> Processing Dependency: php53-xml for package: psa-php53-configurator
    --> Running transaction check
    ---> Package libedit.x86_64 0:3.0-2.20090923cvs.el5.art set to be updated
    ---> Package mysqlclient16.x86_64 0:5.1.57-1.el5.art set to be updated
    --> Processing Dependency: php53 >= 5.3.0 for package: php53-sqlite2
    --> Processing Dependency: php53 for package: psa-php53-configurator
    --> Processing Dependency: php53-cli for package: psa-php53-configurator
    --> Processing Dependency: php53-gd for package: psa-php53-configurator
    --> Processing Dependency: php53-imap for package: psa-php53-configurator
    --> Processing Dependency: php53-mbstring for package: psa-php53-configurator
    --> Processing Dependency: php53-mysql for package: psa-php53-configurator
    --> Processing Dependency: php53-pdo for package: psa-php53-configurator
    --> Processing Dependency: php53-xml for package: psa-php53-configurator
    ---> Package t1lib.x86_64 0:5.1.2-2.el5.art set to be updated
    --> Finished Dependency Resolution
    psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 from installed has depsolving problems
    --> Missing Dependency: php53-xml is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 from installed has depsolving problems
    --> Missing Dependency: php53-pdo is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 from installed has depsolving problems
    --> Missing Dependency: php53-imap is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 from installed has depsolving problems
    --> Missing Dependency: php53-mysql is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 from installed has depsolving problems
    --> Missing Dependency: php53-cli is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 from installed has depsolving problems
    --> Missing Dependency: php53-mbstring is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    php53-sqlite2-5.3.2-11011812.x86_64 from installed has depsolving problems
    --> Missing Dependency: php53 >= 5.3.0 is needed by package php53-sqlite2-5.3.2-11011812.x86_64 (installed)
    psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 from installed has depsolving problems
    --> Missing Dependency: php53-gd is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 from installed has depsolving problems
    --> Missing Dependency: php53 is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    Error: Missing Dependency: php53-mysql is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    Error: Missing Dependency: php53 >= 5.3.0 is needed by package php53-sqlite2-5.3.2-11011812.x86_64 (installed)
    Error: Missing Dependency: php53 is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    Error: Missing Dependency: php53-xml is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    Error: Missing Dependency: php53-gd is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    Error: Missing Dependency: php53-mbstring is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    Error: Missing Dependency: php53-imap is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    Error: Missing Dependency: php53-pdo is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    Error: Missing Dependency: php53-cli is needed by package psa-php53-configurator-1.6.1-rhel5.build1012110525.15.x86_64 (installed)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.
     
    Last edited by a moderator: Aug 2, 2011
  2. Stefan_

    Stefan_ Guest

    0
     
    I have the same problem here :(
     
  3. vincenzot

    vincenzot Regular Pleskian

    22
    40%
    Joined:
    Jul 3, 2009
    Messages:
    104
    Likes Received:
    0
    Compile Mcrypt directly from php-source.
     
  4. Designsteins

    Designsteins New Pleskian

    6
     
    Joined:
    Aug 29, 2013
    Messages:
    1
    Likes Received:
    0
    Hey guys,

    This is the latest thread that I can find addressing this issue. Here is my site info.
    Hostname ns367336.ovh.net
    IP address 94.23.24.197
    OS CentOS 6.3 (Final)
    Panel version 11.0.9

    I am not computer savvy by any means. I feel intimidated just by being on here. I have a Wordpress site that I am putting together. I have purchased a survey/quiz plugin that requires MYCRYPT. I have no idea how to install it, where to begin, or how to know if it is completed correctly. I am desperate to get this done.

    Is there any way that any of you can give me some direction. This is pathetic I know, but I am at the end of my rope! Please help!
     
  5. InderS

    InderS Silver Pleskian

    15
    30%
    Joined:
    Apr 17, 2013
    Messages:
    968
    Likes Received:
    1
    Location:
    Nashik
    Can you please try with the following command and let me know if you are still facing the same issues

    1) Add the atomic repo with:
    Code:
    wget -O - [url]http://www.atomicorp.com/installers/atomic[/url] |sh
    
    2) Install php-mcrypt with:
    Code:
    yum install php-mcrypt
     
  6. DanielL84

    DanielL84 New Pleskian

    4
    70%
    Joined:
    Jun 20, 2014
    Messages:
    10
    Likes Received:
    0
    I know this is an oldish thread, but I have been having this same issue. I have tried the above and it isn't working. Here are my server details:

    Linux
    Centos 5.5
    PHP 5.3.3
    Plesk 12
    x86_64

    Could anyone point me in the right direction getting mcrypt to work on this? Should I be updating Centos 5.5 to 5.10? Should I update PHP to 5.4 or 5.5?
     
Loading...