1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Install/Upgrade Component Failure

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by ElmiraL, Jul 26, 2010.

  1. ElmiraL

    ElmiraL Guest

    0
     
    Hi
    Code:
    error: unpacking of archive failed on file /usr/bin/catchsegv;4c4d46dc: cpio: open failed - Permission denied
    Error: An error occurred during installation of packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.
    
    while Install/Upgrade a Component these massage will be displayed

    and here is the whole message:
    Code:
    Parallels Products Installer 3.6.0 (built on 2010-04-13 11:15 svn rev. 290858) started at (timezone IRST) Mon Jul 26 12:56:43 2010
    Command line arguments: /usr/local/psa/admin/bin/autoinstaller --enable-xml-output --source-type=plesk --target=/root/psa --select-release-id=PLESK_9_5_2 --notify-email=xxxxx@xxxx.com --install-component=base --install-component=atmail
    
    Try to find rcfile...
    Autoinstaller rcfile not found.
    Checking hostname is sucessfull.
    Opsys detected as: os_vendor=CentOS os_name=Linux version=5.5 arch=i686 environment=vz
    Final opsys (with overriding) is: os_vendor=CentOS os_name=Linux version=5.5 arch=i686 environment=vz
    File downloading products.inf3: 100% was finished.
    File downloading plesk.inf3: 11%..21%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading ppsmbe.inf3: 20%..32%..44%..55%..67%..78%..90%..100% was finished.
    File downloading sitebuilder.inf3: 10%..22%..35%..48%..61%..74%..87%..99%..100% was finished.
    File downloading setemplates.inf3: 19%..44%..69%..94%..100% was finished.
    repository: Get brief packages info for all sources
    Checking for installed packages...
    File downloading PSA_9.5.2/plesk-9.5.2-cos5-i386.inf3: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading PSA_9.5.2/plesk-patches-9.5.2-cos5-i386.inf3: 41%..94%..100% was finished.
    Parallels Containers were detected. Trying to connect to VZAgent...Warning! Failed to connect to VZAgent: open: No such file or directory
    repository: Get brief packages info for all sources
    Detecting installed product components.
    Component plesk/base: mode up2date,  installed=1272952336,  available=1272952336
    Component plesk/base have no older version, so keyupdate not needed
    .
    .
    Component plesk/atmail: mode install,  installed=0,  available=1272952243
    KeyUpdateChecker::doCheck: no components for check key update
    repository: Get full packages info for all sources
    Retrieving information about the installed packages...
    read cache file
    File downloading PSA_9.5.2/dist-rpm-CentOS-5-i386/build-9.5.2-cos5-i386.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading PSA_9.5.2/update-rpm-CentOS-5-i386/update-9.5.2-cos5-i386.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading PSA_9.5.2/thirdparty-rpm-CentOS-5-i386/thirdparty-9.5.2-cos5-i386.hdr.gz: 11%..20%..32%..41%..52%..61%..70%..82%..91%..100% was finished.
    Determining the packages that need to be installed.
     skip package 'plesk-base-9.5.2-cos5.build95100504.12.i586' from component base - there is same or newer version of this package is installed (in system plesk-base-9.5.2-cos5.build95100504.12.i586)
     skip package 'plesk-skins-9.5.2-0.291020.noarch' from component base - there is same or newer version of this package is installed (in system plesk-skins-9.5.2-0.291020.noarch)
     skip package 'psa-9.5.2-cos5.build95100504.12.i586' from component base - there is same or newer version of this package is installed (in system psa-9.5.2-cos5.build95100504.12.i586)
     skip package 'psa-api-9.5.2-cos5.build95100504.12.noarch' from component base - there is same or newer version of this package is installed (in system psa-api-9.5.2-cos5.build95100504.12.noarch)
     skip package 'psa-awstats-configurator-1.0.0-cos5.build95100504.12.noarch' from component base - there is same or newer version of this package is installed (in system psa-awstats-configurator-1.0.0-cos5.build95100504.12.noarch)
     skip package 'psa-fcgi-2.4.0-2.i386' from component base - there is same or newer version of this package is installed (in system psa-fcgi-2.4.0-2.i386)
     skip package 'psa-libpam-plesk-9.5.2-cos5.build95100504.12.i586' from component base - there is same or newer version of this package is installed (in system psa-libpam-plesk-9.5.2-cos5.build95100504.12.i586)
     skip package 'psa-locale-base-en-US-9.5.2-2010041911.noarch' from component base - there is same or newer version of this package is installed (in system psa-locale-base-en-US-9.5.2-2010041911.noarch)
     skip package 'psa-logrotate-3.7-cos5.build95100504.12.i586' from component base - there is same or newer version of this package is installed (in system psa-logrotate-3.7-cos5.build95100504.12.i586)
     skip package 'psa-mod-fcgid-configurator-1.0-13.i386' from component base - there is same or newer version of this package is installed (in system psa-mod-fcgid-configurator-1.0-13.i386)
     skip package 'psa-mod_fcgid-1.10-3.i386' from component base - there is same or newer version of this package is installed (in system psa-mod_fcgid-1.10-3.i386)
     skip package 'psa-proftpd-1.3.2e-cos5.build95100504.12.i586' from component base - there is same or newer version of this package is installed (in system psa-proftpd-1.3.2e-cos5.build95100504.12.i586)
     skip package 'psa-proftpd-xinetd-1.3.2e-cos5.build95100504.12.i586' from component base - there is same or newer version of this package is installed (in system psa-proftpd-xinetd-1.3.2e-cos5.build95100504.12.i586)
     skip package 'psa-pylibplesk-9.5.2-cos5.build95100504.12.i586' from component base - there is same or newer version of this package is installed (in system psa-pylibplesk-9.5.2-cos5.build95100504.12.i586)
     skip package 'psa-selinux-9.5.2-cos5.build95100504.12.noarch' from component base - there is same or newer version of this package is installed (in system psa-selinux-9.5.2-cos5.build95100504.12.noarch)
     skip package 'psa-updates-9.5.2-cos5.build95100504.12.noarch' from component base - there is same or newer version of this package is installed (in system psa-updates-9.5.2-cos5.build95100504.12.noarch)
    Warning: unresolved requires 'dbus = 1.1.2-14.el5' from dbus-libs-1.1.2-14.el5.i386
    Warning: unresolved requires 'glibc = 2.5-49.el5_5.2' from glibc-devel-2.5-49.el5_5.2.i386
    Warning: unresolved requires '/usr/bin/fipscheck' from fipscheck-lib-1.2.0-1.el5.i386
    Warning: unresolved requires 'glibc = 2.5-49.el5_5.2' from glibc-headers-2.5-49.el5_5.2.i386
    Warning: unresolved requires 'perl(Digest::SHA)' from perl-Net-DNS-0.66-1.el5.rf.i386
    Check package set before installation
    File downloading PSA_9.5.2/dist-rpm-CentOS-5-i386/opt/atmail/psa-atmail-1.02-cos5.build95100504.12.noarch.rpm: was skipped because of md5 checksum match.
    File downloading PSA_9.5.2/update-rpm-CentOS-5-i386/perl-5.8.8-27.el5.i386.rpm: was skipped because of md5 checksum match.
    File downloading PSA_9.5.2/update-rpm-CentOS-5-i386/glibc-2.5-49.i686.rpm: was skipped because of md5 checksum match.
    File downloading PSA_9.5.2/update-rpm-CentOS-5-i386/glibc-common-2.5-49.i386.rpm: was skipped because of md5 checksum match.
    File downloading PSA_9.5.2/update-rpm-CentOS-5-i386/libgcc-4.1.2-48.el5.i386.rpm: was skipped because of md5 checksum match.
    Starting installation of packages
    Warning: unresolved requires 'psmisc' from psa-9.5.2-cos5.build95100504.12.i586
    Warning: unresolved requires 'mod_perl' from psa-9.5.2-cos5.build95100504.12.i586
    .
    .
    .
    Warning: unresolved requires 'expat = 1.95.8-8.3.el5_4.2' from expat-devel-1.95.8-8.3.el5_4.2.i386
    Warning: unresolved requires 'libexpat.so.0' from expat-devel-1.95.8-8.3.el5_4.2.i386
    Warning: unresolved requires 'perl(Digest::SHA)' from perl-Net-DNS-0.66-1.el5.rf.i386
    Warning: unresolved requires 'avahi = 0.6.16' from avahi-glib-0.6.16-9.el5_5.i386
    Warning: unresolved requires 'libavahi-common.so.3' from avahi-glib-0.6.16-9.el5_5.i386
    Installing the package glibc-common-2.5-49.i386
    error: unpacking of archive failed on file /usr/bin/catchsegv;4c4d46dc: cpio: open failed - Permission denied
    Error: An error occurred during installation of packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.
    
    
    ---
    Parallels Products Installer.
    
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    As I see it is Virtuozzo VPS. I suppose that VPS should be updated with vzpkg command from Virtuozzo node before Plesk updating. Very important glibc-common package will be upgraded with OS upgrade process in this case.
     
  3. ElmiraL

    ElmiraL Guest

    0
     
    How can i do this?
    shall I call to my VPS host owner to i can run it in my own VPS?
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    It should be something like

    vzpkg update VPSID

    from Virtuozzo hardware node.
     
Loading...