1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Installation in Debian 4.0

Discussion in 'Plesk Expand 2.2 Troubleshooting Issues' started by javierBusinet, Oct 8, 2007.

  1. javierBusinet

    javierBusinet Guest

    0
     
    I have chosen the automatic installation and when I execute the script the system can't find expand package.

    I tried first manually and when I get that error then I did it with the automatic script.
     
  2. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Can you post here a text of error the system reports to you?
     
  3. javierBusinet

    javierBusinet Guest

    0
     
    Well, the error is very self-descriptive.


    myServer:/tmp# sh expand-2.2-debian-autoinstall.sh
    Check Debian version... etch
    You are going to install Plesk Expand ver. 2.2...
    Checking apt configuration file...
    Des:1 http://security.debian.org etch/updates Release.gpg [189B]
    Des:2 http://security.debian.org etch/updates Release [22,5kB]
    Ign http://autoinstall.plesk.com debian/etch/ Release.gpg
    Ign http://autoinstall.plesk.com debian/etch/ Release
    Ign http://security.debian.org etch/updates/main Packages/DiffIndex
    Ign http://security.debian.org etch/updates/contrib Packages/DiffIndex
    Ign http://security.debian.org etch/updates/main Sources/DiffIndex
    Ign http://security.debian.org etch/updates/contrib Sources/DiffIndex
    Ign http://autoinstall.plesk.com debian/etch/ Packages/DiffIndex
    Des:3 http://security.debian.org etch/updates/main Packages [181kB]
    Obj http://autoinstall.plesk.com debian/etch/ Packages
    Obj http://security.debian.org etch/updates/contrib Packages
    Des:4 http://security.debian.org etch/updates/main Sources [24,4kB]
    Obj http://security.debian.org etch/updates/contrib Sources
    Descargados 228kB en 1s (116kB/s)
    Leyendo lista de paquetes... Hecho
    (reading package list...done)
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias... Hecho
    (creating dependencies tree...done)
    E: No se pudo encontrar el paquete expand (can't find expand package)


    I think I'm doing something easy wrongly.
     
  4. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Could you show us /etc/apt/sources.list file. Our engineers can not reproduce the problem on their machines.
     
  5. javierBusinet

    javierBusinet Guest

    0
     
  6. javierBusinet

    javierBusinet Guest

    0
     
    I tried to install Plesk 8.2 too on other server and I have a similar problem:



    Seleccione los componentes que desea instalar:

    1. [*] Base packages of Plesk
    2. [*] Plesk Updater
    ........
    41. [*] Chinese language pack for China
    42. [*] Chinese language pack for Taiwan

    N) Siguiente página; P) Atrás; Q) Cancelar instalación;
    A) Seleccionar todo; D) Deseleccionar todo;
    Si desea seleccionar o deseleccionar un componente, indique el número de este;
    Introduzca un número o caracter de la acción deseada [N]:
    Intercammbiando información con el servidor de licencias.
    Comprobando si las dependencias del paquete están resueltas.
    E: Broken packages
    ERROR: Unable to install packages because of package dependency problems.
    No se han instalado todos los paquetes.
    Contacte con el equipo de soporte técnico del producto.



    My sources.list is:


    # deb cdrom:[Debian GNU/Linux 4.0 r1 _Etch_ - Official amd64 CD Binary-1 200708$

    #deb cdrom:[Debian GNU/Linux 4.0 r1 _Etch_ - Official amd64 CD Binary-1 2007081$

    deb ftp://ftp.rediris.es/debian/ etch main non-free contrib
    deb http://security.debian.org/ etch/updates main contrib
    deb-src http://security.debian.org/ etch/updates main contrib
     
  7. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Well, we can not discover what is the problem reason unfortunately, but we can suggest a manual installation if automated one does not work. Follow the instructions below.

    Download this file to your server http://download1.swsoft.com/Plesk/Expand/2.2.1-Release1/tarballs/expand_2.2.1-27.deb40.tar

    Then remove the following lines
    Code:
    #
    # added by Expand: Plesk Expand 2.2 Debian repository
    #
    deb [url]http://autoinstall.plesk.com/Expand/2.2[/url] debian/etch/
    
    from /etc/apt/sources.list

    Then follow this chapter from our release notes:

    Code:
       Manual Installation From Tarball
    
       Plesk Expand and required software are distributed in the DEB packages
       rolled into a single tarball:
    
         * Debian GNU Linux 3.1:
           expand_2_2_1-27.deb31.tar
         * Debian GNU Linux 4.0:
           expand_2_2_1-27.deb40.tar
    
       To install Plesk Expand, follow these instructions:
    
        1. Log in as 'root' to your system.
        2. Decompress an appropriate Plesk Expand archive:
    
             # tar xf expand_2_2_1-27*.tar
    
        3. Update your /etc/apt/sources.list file, insert into it one of the
           following lines according to your OS:
    
              * For Debian GNU Linux 3.1
    
             deb file://<path> expand_2_2_1-27.deb31/
    
              * For Debian GNU Linux 4.0
    
             deb file://<path> expand_2_2_1-27.deb40/
    
           NOTE: Specify a path to decompresed directory instead of <path>
    
        4. Resynchronize the apt-get package index files:
    
             # apt-get update
    
        5. Install Plesk Expand:
    
             # apt-get install expand expand-dist-repository
    
    Either you can contact our support service with that problem. Having an access to your server out engineers can resolve this issue probably.

    Thank you
     
  8. javierBusinet

    javierBusinet Guest

    0
     
    I have tried to install it manually but I've got the same problem:

    myServer:/tmp# apt-get install expand expand-dist-repository
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias... Hecho
    E: No se pudo encontrar el paquete expand(can't find package expand)

    My sources.list is:

    deb http://security.debian.org/ etch/updates main contrib
    deb-src http://security.debian.org/ etch/updates main contrib
    deb ftp://ftp.rediris.es/debian/ etch main non-free contrib
    deb file:/tmp/ expand_2.2.1-27.deb40/

    And my tmp folder is:
    myServer:/tmp# ls
    expand_2.2.1-27.deb40 expand-2.2-debian-autoinstall.sh
    expand_2.2.1-27.deb40.tar


    Thanks for your replies.
     
  9. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Well, so contacting support service is the only choice I think.
     
Loading...