1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Installed 7.5.2 patch and getting "Can't create Domain"

Discussion in 'Plesk for Windows - 8.x and Older' started by hiebosch, May 5, 2005.

  1. hiebosch

    hiebosch Guest

    0
     
    We've just bought and installed plesk on new server. Since the 7.5.2 patch has come out we decided to install it.

    Now when I try to "create new domain" for client I get following error message:

    Seems like a number of problems... error message seems to start with plesk system problems (mailManager->addDomain() faile) all the way to IIS error (COM Error 800A035...). Or maybe it's one problem... not sure.

    I think I'm missing something in the configuration someplace.

    Anyone with any ideas?
     
  2. flyby

    flyby Guest

    0
     
  3. marcelowelter

    marcelowelter Guest

    0
     
    COM Error 80020009 (Exception occurred.) at setAppPoolIdentity

    on creating new domains...

    some are a bad small on this version 7.5.2
     
  4. flyby

    flyby Guest

    0
     
    on installation :)
     
  5. marcelowelter

    marcelowelter Guest

    0
     
    all stay ok, but some days ago have this troubles

    the box work okay for 2 months and now i cant crete new domains or my resellers and not cant delete or change many domains...

    terrible
     
  6. fabianomaciel

    fabianomaciel Guest

    0
     
    This is the same error that was posted by Welter

    COM Error 80020009

    The domain is not created, during the execution of websrvmng.exe the application pool is created and the user IWPD_xxxx is also created, only that after the fault, it is probably made a rollback of everything and the appl poll is excluded and the user IWPD_xxxx is also excluded.
    After this error, IIS is unstable.
    I would like to know the steps that are done for the physical creation of the host, because this error is related with the physical creation, and knowing about the steps, it could try to identify some problem in Windows.

    thanks,

    Fabiano Maciel
     
  7. knocx

    knocx Guest

    0
     
    we got the same situaiton here;

    the integration of PLESK and IIS is quite lost. Actually i believe that problem is basicly with IIS somehow and what causes is may be we gor 250 sites runinng on IIS

    we can not even start stop domains on IIS, IIS hangs on restart...etc

    i am now trying to resolve this issue, any help would be great

    -- knocx
     
  8. hiebosch

    hiebosch Guest

    0
     
    I'm not sure where the problem is.

    I think something is corrupted in plesk -- that is causing problems for IIS.

    Because "create domain" in plesk starts a whole chain of updates to IIS module, something isn't being written correctly somewhere.

    For me -- I solved the problem by uninstalling the whole plesk program and reinstalling plesk 7.5.1. But I'm not a live server with lots of websites.

    Not sure what the solution is ....Restore to back up prior to patch install?... trying to install patch again...? Finding another domain management software....?

    Best of luck all!
     
  9. knocx

    knocx Guest

    0
     
    we have just restared the installation to a freash server allready... I believe somehow IIS get into an unstable state...

    We can not stop a site from iis neither we can restart IIS, seems no relation with plesk

    -- knocx
     
  10. Togy

    Togy Guest

    0
     
    Windows 2003 Plesk 7.5.2 domain creating issue

    I have same problems while adding domain from control panel. Only solution is apply command "iisreset /restart" from msdos command prompt then re-create domain from plesk and this is very bothering and furstrating. Error code example in event manager below :

    SW-SFOT realy should fix this problem ASAP.
    --------------------
    COM Error 80020009 (Exception occurred.) at setAppPoolIdentity(oxis.com(domain)(pool), IWPD_163(oxis))
    at (WebServerAdapter::setAppPoolIdentity line 2787)
    at addAppPool(oxis.com(domain)(pool), IWPD_163(oxis))(WebServerAdapter::addAppPool line 2840)
    at addAppPool(oxis.com(domain)(pool), IWPD_163(oxis))(WebServerAdapter::addAppPool line 2854)
    at execute console command --install-vhost(vconsoleapp::start line 128)
    at execute "C:\Program Files\SWsoft\Plesk\/admin/bin/websrvmng" --install-vhost "--vhost-name=oxis.com"(vconsoleapp::run line 138)
    Execute file name: C:\Program Files\SWsoft\Plesk\admin\bin\websrvmng.exe
    --------------------
     
  11. ColorPrint

    ColorPrint Guest

    0
     
    I have the same problem :(
    Anybody know how to solve it?
     
  12. ColorPrint

    ColorPrint Guest

    0
     
    for each such domain I'm:
    1) restarted IIS
    2) run: websrvmng --reconfigure-vhost --vhost-name=my-domain-name.com
    :(
     
  13. fabianomaciel

    fabianomaciel Guest

    0
     
    And SWSoft. is not it pronounced on the problem????
    It is a serious problem, the plesk is very unstable. Several BUG´s exist in the plesk, mainly if the client submits several times the same page, what already happened with me... simply the plesk burdens two or more inputs in DNS.... generating like this an error in DNS and the service of the same finishing. I think the support of the company SWSoft is very weak. Fortunately soon we will have the version of Cpanel for Windows.
    On the problem of IIS, I believe that it is some instability in IIS also, but Plesk was able very well to generate more detailed LOG´s of the operations, we could analyze like this with more details the problem and knowledge through where to begin to investigate..

    Fabiano.
     
  14. Togy

    Togy Guest

    0
     
    I believe that problem cause if you set dedicated application pool for each domain. Login control panel as admin and click "server", click "Application pool > Global settings" set shared application pool , middle of choices...

    If you checks event viewer you'll see that problem comes while setup application pool..... With this new setting plesk will setup one application pool and than probably will not give same errors.... I know 2003's best thing is you can see each process of websites and this way you'll no longer able to see each website process but you'll rid of stress...

    I'll keep posting here if i got new problems about same issue...
    Hopefully sw-soft reads this posts atm....
     
  15. fabianomaciel

    fabianomaciel Guest

    0
     
    Yes, does that work, but does it imagine that if I need to do a stop in a site? I have to stop all, this is one of the objectives of ApplicationPool. I think that is not a way to solve the problem, only the problem is outlined.

    Fabiano Maciel.
     
  16. Troy

    Troy Guest

    0
     
    We've been having these same issues creating domains, ever since updating to 7.5.2. Here's what we've done to stabilize things and at least keep our servers running:

    1. As suggested earlier in this thread, Perform an "iisreset /restart" immediately before creating new domains.

    2. Give domains a dedicated application pool.

    3. Do not allow PHP to run as an ISAPI. I haven't yet dug into this one to find out what exactly is wrong, but if a site is configured to run PHP as ISAPI, the site won't work at all, even non-PHP documents aren't accessible, nothing works. Turn off PHP as ISAPI and everything is fine.

    Just thought I'd post in case it helps someone.
     
  17. fernoliv

    fernoliv Guest

    0
     
    Hello Fabiano, good night!

    I have same very serious problems with Plesk in my provider.

    You are brazilian civilian?

    Please contact me via MSN or e-mail: fernando_s_o@yahoo.com.br.

    My provider is www.ultraespaco.com.br and my sites on windows are down for problems with Plesk 7.5.3.

    Regards,

    Fernando Oliveira
     
  18. notjake

    notjake Guest

    0
     
    0x800A0035

    Failed domain creation: Unable to update domain data: Failed mail post-configuration: Can't create mail domain servie: mailManager->addDomain() failed: mailmng failed: COM Error 800A035 (Unknown error 0X800A0035, File not found: MEAIPO.DLL) at execute console command --add-domain.

    Can you run the mailmng command from the bin directory of mail enable ?

    If so make sure you have an environment variable of the following details.

    %pleskroot%\Mail Servers\Mail Enable\bin

    If not add this and it should find the .dll correctly.

    I had a similiar issue with listmng.exe not finding MEAILS.DLL

    You must reboot after adding environment varibales.

    Jake.
     
Loading...