• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Internal Error: Unable to load object of type BsDomain with id=: Trying to create...

B

BurkhardA

Guest
[FIXED]Internal Error: Unable to load object of type BsDomain with id=: Trying

[EDIT]I'll give an short description of fix later the day[/EDIT]

Product: Plesk Panel 10.2.0 (psa-10.2.0-suse11.3.build1011110331.11)
OS: OpenSuSE 10.3
Kernel: Linux 2.6.34.7-0.5-default
Architecture: x86_64
MTA: postfix-2.7.1-2.6.1

Problem Description:
When trying to add new Mail-Adresses, Plesk states Internal Error

Steps to reproduce:
Domains -> domain.tld -> Control Panel -> E-Mail -> Add new Email-Address

Actual Results:
When adding a new mailadress to a Domain I get this Error:
Unable to load object of type BsDomain with id=: Trying to create class BsDomain for not-existent client. (Screenshot attached)
Trying to migrate mails from another host results in the same errors.
Mailsystem as such works (existing mailadresses work as expected)

Expected Results:
Adding new Mail-Adresses should work.





Thanks, in advance,

Hinkmar



Additional Information:

The error occured, after setting mysql sql-mode to "NO_AUTO_VALUE_ON_ZERO", not sure if related, disabling the sql-mode does not change described behaviour.

Logs:

hostname:/usr/local/psa/admin/logs # tail panel.log
code: 0
2011-08-05T10:45:04+02:00 ERR (3): mail does not exist
2011-08-05T10:45:08+02:00 CRIT (2): Smb_Exception: Unable to load object of type BsDomain with id=: Trying to create class BsDomain for not-existent client.
file: /usr/local/psa/admin/smb/application/library/Smb/Plesk/Bridge/Domain.php
line: 54
code: 0
2011-08-05T10:45:13+02:00 CRIT (2): Smb_Exception: Unable to load object of type BsDomain with id=: Trying to create class BsDomain for not-existent client.
file: /usr/local/psa/admin/smb/application/library/Smb/Plesk/Bridge/Domain.php
line: 54
code: 0
 

Attachments

  • pleskerror.png
    pleskerror.png
    34.8 KB · Views: 17
Last edited by a moderator:
Fix

To cite myself:
"The error occured, after setting mysql sql-mode to "NO_AUTO_VALUE_ON_ZERO", not sure if related, disabling the sql-mode does not change described behaviour."
After checking
http://pleskhacker.com/all-tables/psa_mail/
I found in my psa/mail table an entry with id=0 with the last addet mail-adress.
Deleted sql-mode = "NO_AUTO_VALUE_ON_ZERO" from my my.cnf, restarted mysql.
Edited the entry with id 0 to the next free and valid id.
-> fixed

@me:
i am an idiot for setting the sql mode only because a bug in some php software.

@parallels:
i don't think relying on the "auto-correction-feature" of mysql which forbids/corrects 0-values is a good idea.
a documentation of your psa-database like in the link above would be great for debugging.

Have a nice evening/weekend,

Hinkmar
 
Back
Top