1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

ISAPI Rewrite not working with a Plesk site

Discussion in 'Plesk for Windows - 8.x and Older' started by dzigrino, Feb 17, 2005.

  1. dzigrino

    dzigrino Guest

    0
     
    Hi,

    I have used Plesk 7 to set up a website on a Windows 2003 server. The website is working and returning requests. On the same machine I have installed ISAPI_REWRITE. When I set up the configuration file (httpd.ini) in the root folder of the site, it should redirect via the ISAPI filter but it doesn't. I know the ISAPI_REWRITE filter is working because I went into IIS and set up a website directly. That website will redirect properly (using the same httpd.ini file as the non-working website).

    Plesk sets up a separate application pool with a separate user for each website. I have given that user full privileges to all the dll's for ISAPI_REWRITE as well as the rwhelper.dll.manifest file, the httpd.ini file (global AND website specific), and the httpd.parse.errors (global AND website specific).

    I have seen others on the Plesk forum that say they have Plesk and ISAPI_REWRITE working together. What extra configurations are needed that I am missing? I am posting this query to the Plesk forum and the ISAPI_REWRITE forum in the hope that someone might point me in the right direction.

    One thing that I wouldn't think matters (but might) is that the server is actually a virtual server sitting on top of Virtuoso.

    Thank you,
    Danny
     
Loading...