1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Java Applications section not available

Discussion in 'Plesk 11.x for Linux' started by AshDav, Dec 6, 2012.

  1. AshDav

    AshDav New Pleskian

    10
    35%
    Joined:
    Dec 6, 2012
    Messages:
    9
    Likes Received:
    0
    Hi,

    I'm trying to activate the 'Java Appications' section on Plesk 11 in the Advanced Operations section under Websites & Domains. This is for a DV server run through MediaTemple.

    This is the button I'm trying to find. For some reason this Java Applications section isn't visible at all on my server.

    Is there an option I need to select or an add on to use that will make this section appear?

    Any help will be greatly appreciated :)

    Ash
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Do you have Tomcat installed on your Plesk server?
     
  3. AshDav

    AshDav New Pleskian

    10
    35%
    Joined:
    Dec 6, 2012
    Messages:
    9
    Likes Received:
    0
    I have tried to install Tomcat. It says the service is running although I can't see anything different in Plesk.
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Make sure that you have enabled corresponding permissions in subscription.
     
  5. AshDav

    AshDav New Pleskian

    10
    35%
    Joined:
    Dec 6, 2012
    Messages:
    9
    Likes Received:
    0
    Under 'Access to Panel services' for the Administrator user, everything is set to granted. Is this the field you mean?
     
  6. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    I mean " Java applications management" permission in subscription.
     
  7. AshDav

    AshDav New Pleskian

    10
    35%
    Joined:
    Dec 6, 2012
    Messages:
    9
    Likes Received:
    0
    I unfortunately can't find anything to do with Java Applications Management or any field labeled subscription. Where should I be looking for this?

    Is there a way to check if the tomcat install is working properly?
     
  8. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Looks like you have enabled Power View mode instead of Service Provider mode. Check it in Tools & Settings>
    Interface Management
     
  9. AshDav

    AshDav New Pleskian

    10
    35%
    Joined:
    Dec 6, 2012
    Messages:
    9
    Likes Received:
    0
    Ok this view looks more promising! I'm now in Service Provider mode and I've gone ahead and enabled Java Applications in the subscriptions permissions.

    Still not able to see the 'Java Applications' button noted in the first post. Not 100% sure Tomcat is working for me. Just stopped Tomcat through SSH and received this notice

    I'm thinking this could have something to do with the issue. Here's that chunk of the config file:
     
  10. AshDav

    AshDav New Pleskian

    10
    35%
    Joined:
    Dec 6, 2012
    Messages:
    9
    Likes Received:
    0
    Still not seeing any Java Applications field. With Tomcat installed, should this section now be active?
     
  11. DaveKay

    DaveKay Regular Pleskian

    17
    85%
    Joined:
    Jan 2, 2012
    Messages:
    226
    Likes Received:
    0
    Possibly a silly question, but are you sure you have Java Applications as part of your license? Some VPS hosts issue "restricted" licenses...

    You can check under Tools & Settings > License Management
     
    Last edited: Dec 9, 2012
  12. AshDav

    AshDav New Pleskian

    10
    35%
    Joined:
    Dec 6, 2012
    Messages:
    9
    Likes Received:
    0
    Just checked and Java Applications are apart of my license. Certainly worth checking though!
     
  13. DaveKay

    DaveKay Regular Pleskian

    17
    85%
    Joined:
    Jan 2, 2012
    Messages:
    226
    Likes Received:
    0
    Just try something quickly, change the uppercase M for a lowercase m in your config file.

    So it should be:

    JAVA_OPTS=-Xms128m -Xmx448m

    I believe they are case sensitive...
     
  14. AshDav

    AshDav New Pleskian

    10
    35%
    Joined:
    Dec 6, 2012
    Messages:
    9
    Likes Received:
    0
    I changed the M to lowercase but I'm still seeing that error message whenever I start/stop tomcat in SSH.

    When starting it like this, the servers memory overloads and goes crazy. The only way I've found to avoid the memory issues is to put the line in quotes:
    Then I don't get the error on startup and the servers memory is ok, but I'm still not seeing a Java Applications field :S
     
  15. DaveKay

    DaveKay Regular Pleskian

    17
    85%
    Joined:
    Jan 2, 2012
    Messages:
    226
    Likes Received:
    0
    Apologies! Obviously not the fix then!
     
  16. AshDav

    AshDav New Pleskian

    10
    35%
    Joined:
    Dec 6, 2012
    Messages:
    9
    Likes Received:
    0
    Really appreciate your help :)
     
Loading...