1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Key error after upgrading to version 9.0

Discussion in 'Plesk 9.x for Windows Issue, Fixes, How-To' started by moonlight, Dec 16, 2008.

  1. moonlight

    moonlight Guest

    0
     
    Hi,

    I get this error message after I had upgraded from Plesk 8.6 to 9.0 on my Windows 2003 maschine:

    <Fatal error: Call to undefined function of_get_key_by_product() in C:\Programme\SWsoft\Plesk\admin\plib\common_func.php3 on line 4506

    Also I have found two issues loged in the EventLog which was created on the upgrade by My-SQL upgarde issue with the my.ini file.

    Is there a way to fix this or had I made a new install and create new all Users and Domains? I am not sure at this point if the backup whish I had made with 8.6 will later restoring without issues in the Plesk 9.0. If there is a way, please tell it to me.

    Thanks
     
  2. alta

    alta Regular Pleskian

    26
     
    Joined:
    Sep 27, 2007
    Messages:
    118
    Likes Received:
    0
    Please check and make sure that psaadm user have full access for C:\Program
    Files\SWsoft\Plesk\admin\repository
     
  3. TheSimon

    TheSimon Guest

    0
     
    I got the same problem and fount the solution here - http://forum.parallels.com/showthread.php?t=82548
    I renamed the empty "registry.xml" file and reinstalled the license from the license XML file, restarted the services and the plesk worked again.
    (When I tried to regenerate the file without renaming the old file, I just got an error)
     
Loading...