1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Key not found after upgrading to 7.5.4

Discussion in 'Plesk for Linux - 8.x and Older' started by ingber, Nov 24, 2005.

  1. ingber

    ingber Guest

    0
     
    I'm a new user to Plesk - got it in a dedicated server, but version 7.50. Tried to upgrade through the CP to 7.5.4 and now when trying to access the CP, it says (in a blank screen):

    "The file constants.php3 is part of Plesk distribution. It cannot be run outside of Plesk environment."

    So, I didn't give up. When tried to start psa from the shell (after issuing a 'stopall', I got:

    ---------------------------------------------------------------------------------
    root# /etc/init.d/psa start
    ===> Reading /etc/psa/psa.conf ...
    Starting xinetd: [ OK ]
    Starting named: [ OK ]
    Starting MySQL: [ OK ]
    Starting qmail: [ OK ]
    Starting Courier-IMAP server:
    Starting imapd [ OK ]
    Starting imap-ssl [ OK ]
    Starting pop3 [ OK ]
    Starting pop3-ssl [ OK ]

    Starting spamd: [ OK ]
    Starting psa-spamassassin service: [ OK ]
    Processing config directory: /usr/local/psa/admin/conf/httpsd.*.include
    /usr/local/psa/admin/bin/httpsdctl start: httpd started
    Starting Plesk: [ OK ]
    Starting up DrWeb(R) daemon: Dr.Web (R) daemon for Linux/Plesk Edition, version 4.32.2 (2004-09-28)
    Copyright (c) Igor Daniloff, 1992-2004
    Doctor Web Ltd., Moscow, Russia
    Support service: http://support.drweb.com
    To purchase: http://buy.drweb.com

    Engine version: 4.32b
    Loading /var/drweb/bases/drwtoday.vdb - Ok, virus records: 602
    Loading /var/drweb/bases/drw43310.vdb - Ok, virus records: 853
    [........ here were dozens of lines like these ......]
    Loading /var/drweb/bases/drw43201.vdb - Ok, virus records: 364
    Total virus records: 95171
    Key file not found!
    Plesk authorization failed: malformed response (no 'response=' field).
    Error: Plesk Software not running.
    [FAILED]
    ---------------------------------------------------------------------------------

    It sounds like my 7.5.4 upgrade didn't go through, and now I'm in limbo...

    My key file is there at: /etc/psa/psa.key

    Any suggestions???

    Thanks in advance for any help,
    -daniel
    ps: happy turkey day for everyone!
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    That particular "key not found" error is referring to the DrWeb key file. This is normal since you have the 'free' or 'trial' version of DrWeb. Just above the begin of the DrWeb items, it shows:
    Check your /tmp directory for the installer or updater log file. Check carefully to find any warnings or failures in this log, which would indicate that the 7.5.4 did not complete or had problems.

    Also, the Plesk license key from 7.5.0 should be upgraded to a 7.5.4 license key for proper operation.
     
  3. ingber

    ingber Guest

    0
     
    Thanks ShadowMan for taking the time to post your answer.

    I went ahead and tried to install again using rpm instead, and after a few mistrials it finished ok and now it works :)

    Seems the 7.5.0 key works as well...

    Thanks again!
     
  4. ShadowMan@

    ShadowMan@ Guest

    0
     
    The old key is 'supposed' to auto-update, I only mentioned that earlier in case it did not. But if it's working, then it must have auto-updated to a new key.
     
Loading...