1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

local Customer & Business Manager cannot access links

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Andrelt, May 16, 2011.

  1. Andrelt

    Andrelt Guest

    0
     
    I recently update my plesk panel 10.0.1 to add the local Customer & Business Manager. After do the update, it showed not errors, but when i tried to access the panel is did a redirect to port 11444/relay. I used the KB to address this matter and now i can access the panel after trial and error, well now that i can access the panel, here is my problem now
    my business Management section of plesk only display links to blank pages. such as :

    https://edifier.b1fam.com:8443/ples...//66.76.161.72:8443&context=billing-customers

    i have three new sections after the udpate displaying in the panel:

    business operation
    link
    link

    business monitor
    link
    link
    business update
    link
    link
    These links in my panel lead no where, i need to correct this please help
     
  2. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Hi, Andrelt

    Did you use http://kb.odin.com/en/111266 to address your issue?
    Have you tried to execute a command:
    shell> /usr/share/plesk-billing/repair-integration --command=repair-all --idp-url=https://edifier.b1fam.com:8443
     
  3. Andrelt

    Andrelt Guest

    0
     
    the command
    /usr/share/plesk-billing/repair-integration --command=repair-all --idp-url=https://edifier.b1fam.com:8443

    does not exist in the plesk-billing folder, so what can i do. i keep getting no command found
     
  4. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Let's start from the beginning...

    What version of Panel/CBM do you use now?
    What KB do you use to fix issues with login?
     
  5. Andrelt

    Andrelt Guest

    0
     
    My Plesk Panel shows it is version 10.0.1 across the top of the screen, and i installed the recommended CBM from the update components link.
    Customer & Business Manager (free, recommended for shared hosting)

    If you want to know more detailed information about the panel, you will have to tell how to locate it. I anxious await your response. I want to really solve this issue, thanks ahead of time.....
     
  6. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
  7. Andrelt

    Andrelt Guest

    0
     
    EugeneL,

    My panel login link https//edifier.b1fam.com:8443 or https//66.76.161.72:8443, Yes i am able to login to the panel, and NO i cannot login to the CBM directly to access the /plesk-billing/admin/, this path goes to a page that states server not found.
    3. yes i do see the links in the CBM pertaining to the CBM update, I cannot use them, all of the CBM links lead to the standard no server found page, I want to see if you could walk me through different options in troubleshooting. I have your email address if that does not work.
     
  8. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Unfortunately I can't access to your hostname/IP - maybe firewall blocks my IP.

    What KB did you use to address the issue?
    And what was the issue? In 10.0.1 version it Panel must redirect you to SSO relay located on 11444 port.
     
  9. Andrelt

    Andrelt Guest

    0
     
    I used KB http://kb.odin.com/en/111266, The server that i have the Plesk Panel on was down for Maintenance yesterday. So that is why you could not access the links i sent to you. PLease try again. this is what the original error displayed after i did the CBM addition to my plesk panel

    http://edifier.b1fam.com:11444/relay
     
  10. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Oops... If you look at KB article more carefully, you will see that it's applicable for Plesk Panel 10.2 only.

    Try to revert all your changes:
    1. in /etc/sso/sso_config.ini set relay port to 11444
    2. in sso settings set correct server and relay URLs
    /usr/local/psa/bin/sso -s -server https://<your-domain-name>:11443 -url https://<your-domain-name>:11444
    /usr/local/psa/bin/sso -e
    3. set correct settings in psa database
    sso_relay = https://<your-domain-name>:11444
    sso_server = https://<your-domain-name>:11443
    sso_server_user_url = https://<your-domain-name>:11444
    4. restart sw-cp-server
    /etc/init.d/sw-cp-server restart

    P.S.
    I still can't access to your server even using IP address.
    And it seems to be useless since you haven't provided me with credentials.
     
  11. Andrelt

    Andrelt Guest

    0
     
    I am not sure which credentials you need, ftp access ? control panel access ? Let me know which and i will Personal message it to you
     
  12. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    To access panel and to look at its state I need Panel credentials.
    If you want me to try to troubleshoot the issue on my own, I'll need SSH access.
     
  13. Andrelt

    Andrelt Guest

    0
     
    I sent my credentials thru PM
     
Loading...