1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Locked out from Remote Administration

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by RodStr, Jan 25, 2011.

  1. RodStr

    RodStr Basic Pleskian

    21
     
    Joined:
    Jan 18, 2011
    Messages:
    50
    Likes Received:
    0
    Plesk 10.0.1 - Windows 2008 R2 Std - x64 running under VMWare 4

    Was following along with some instructions I found on here about clearing the "IP pool is empty" error
    when setting up new subscriptions.

    Added an IP address into the IP screen, and was IMMEDIATELY booted from the interface.
    I was working from my desktop so accessing the server at https://the_public_IP:8443
    I can no longer access that URL from ANY machine.

    I can however still login directly from the HOST machine using https://127.0.0.1:8443

    Removed the IP that I added, and started getting some other error when trying to add subscriptions
    something about IP_ID=4 not found. Found the article on here about that, executed the dbclient command
    to flush that IP_ID from the IP_POOL table, and that error cleared.

    Now I am still left UNABLE to access the https://the_public_IP:8443 from anywhere.

    Thoughts ? Ideas ? Anyone run into this before ?

    Rod
     
  2. siscom

    siscom Guest

    0
     
    I have a similar issue. If I try and access the Plesk panel from a remote computer using the url it redirects to a wrong URL which is not accessible from the outside.

    EG:

    https://hosting.com:8443 is the correct URL. This is changed to https://host-web:8443/relay and get "This webpage is not available."

    host-web is the "Full computer name" given to the Win2003 server the Plesk panel is installed on. I did not have this issue with Plesk 9.5.

    Of course if I RDP into the server and try from there host-web resolves and I am able to login.

    Chris
     
  3. RodStr

    RodStr Basic Pleskian

    21
     
    Joined:
    Jan 18, 2011
    Messages:
    50
    Likes Received:
    0
    I submitted a ticket for this issue this morning.

    Will post up the fix once it's all figured out.


    Rod
     
  4. siscom

    siscom Guest

    0
     
    Hi,

    I resolved this issue. You need to do this from two places.

    1) using sso.exe (mine was located here C:\Program Files\SWsoft\Plesk\admin\bin)

    If you run "sso.exe -g"

    You will get similar output

    > SSO status: on
    > SSO server url: https://[B]WRONGDOMAIN[/B]:8443
    > SSO API version: sw:sso:idp:1_0

    To change the URL then run sso.exe -s -server https://YOURCORRECTDOMAIN:8443

    2) Editing the Database

    Find Table "cl_param" in database "psa"

    Find "ppb-url" in column param and you will see that the entry is wrong in colum "val" change it to correct URL.

    SQL to check entry: "SELECT * FROM cl_param WHERE param = 'ppb-url';"
     
  5. RodStr

    RodStr Basic Pleskian

    21
     
    Joined:
    Jan 18, 2011
    Messages:
    50
    Likes Received:
    0
    Thanks for the reply, but my server isn't using SSO.

    sso -g

    SSO status: off
    SSO server url:
    SSO API version:

    Sure wish someone at Parallels would at least READ my ticket.
    Supposed to be 12h or less response, has been 25h already and ticket is still marked as UNREAD.

    Not impressed with the Technical Support so far.

    Rod
     
  6. RodStr

    RodStr Basic Pleskian

    21
     
    Joined:
    Jan 18, 2011
    Messages:
    50
    Likes Received:
    0
    Well, the Plesk Tier-2 Support "Solution" was to turn off the Windows Firewall Service.

    Granted, it resolves the issue, but now there is a big "hole" in the Plesk interface for Settings/Firewall.
    Plesk advertises this as "its own" firewall, but this demonstrates quite clearly that without the Windows
    Firewall, the Plesk Firewall doesn't work.

    We are behind a hardware firewall, so it doesn't really matter, but this seems to me like taking the
    "easy way out". Instead of figuring out what is wrong in getting to IIS on port 8443, in other words
    what is it that Plesk misconfigured in the Firewall (or corrupted)... simply shut it down instead.

    Not happy, but willing to accept it for now.

    Rod
     
Loading...