1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Log Rotation Preferences

Discussion in 'Plesk for Linux - 8.x and Older' started by edispah, Nov 30, 2005.

  1. edispah

    edispah Guest


    Im using Plesk 7.5.3 on Fedora Core 2, I have Log Rotation Preferences set for a domain as follows

    Log Rotation Condition - by time "Daily"
    Maximum number of log files - 5
    Compress log files - ticked
    Send processed log files to e-mail user@mydomain.co.uk

    (where user@mydomain.co.uk is a real email)

    Everything works except the email to the user?

    Ive checked in /usr/local/psa/etc/logrotate.d/domain.co.uk and the files looks ok it has at the end of each section

    mail user@mydomain.co.uk

    The strange thing is when I first enabled this I did get an email with the stats 3 days running but for the last 3 days ive not had any?

    Any ideals? Thanks in advance

  2. edispah

    edispah Guest


    Some further info, I can see theres a mysql table called logrotation.

    It has the following set

    id = 2
    period_type = by_time
    period = daily
    max_number_of_logfiles = 5
    compress_enable = true
    email = paul@vsl-net.com
    turned_on = true

    The log files are rotating fine and the timestamps of the rotated logs are always around 4.20am which is when the cron.daily stuff is running.

    Im just not getting the email, ive checked /usr/local/psa/var/log/maillog and no emails are being sent at that time so its not like its sending the email?

    Anyone any ideals, ive got a customer who requires the log to be emailed but I just cant get it working.