1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mail dead after Upgrade-attempt

Discussion in 'Plesk for Linux - 8.x and Older' started by AlleyKat, Apr 4, 2006.

  1. AlleyKat

    AlleyKat Guest

    0
     
    Mail dead after Upgrade-attempt (Solved?)

    I hit Upgrade last night, assuming it was something like an update. I was wrong, it seems.

    Actually, nothing happened. Nothing at all - I hit "Upgrade to 8.0", confirmed that it should start - and nothing whatsoever happened thereafter. I'm quite patient so after 4-5 hours of busy nothing, I checked, and nothing seemed to have changed. But it certainly had.

    When qmail was restarted over the morning, it had a tendency to shut down after a few minutes - not like it usually does, stall sending mails, queueing them until restarted every hour.

    After having restarted it more than 50 times along the day, I tried restarting the server instead. I don't think I should have done that.

    I see the following in my rpm list:
    psa-autoinstaller-3.0.0-build060321.19
    psa-migration-manager-7.5.4-fc3.build75060321.20
    courier-imap-3.0.8-fc3.build80060331.13
    psa-php4-configurator-1.0.0-fc3.build80060331.13
    psa-proftpd-xinetd-1.2.10-fc3.build80060331.13

    (FC3)

    I'm almost 100% sure that what I need to do is uninstall the wrong builds and install the right ones, but where do I find the original psa courier? I thought I had it in my plesk repo, but that seems to be the '-add' package, so I'm kinda stuck...

    Help, please? [All our mail services were down...]


    PHEW! After pulling hair out for hours, I found the full Plesk package download and extracted the couple of elements I needed from there.

    Solution:
    (mostly inspired by Cranky's advices in 8.0 forums)
    Uninstall new qmail, courier-imap (rpm -e <package>),
    Install 'old' versions and the courier-imap-add (rpm -Uvh <package>)
    Stopped the drwebd service AND DrWeb in Plesk -> server -> service management.
    Mail works again.

    But my errorlogs are still looking spooky, so any advice on how to 'unroll' are welcome.I have lists of the rpms from a few days before - should I make the rpm lists match? And would it help (me, you, swsoft) posting them here?
     
Loading...