1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mail problems

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by John Fleming, Jun 4, 2012.

  1. John Fleming

    John Fleming Basic Pleskian

    17
    85%
    Joined:
    Jul 11, 2010
    Messages:
    28
    Likes Received:
    0
    Hi all,

    I have a problem that has cropped up and I am not sure how to fix it.

    I have a domain hosted in Plesk, and the client has setup their own mail server, and so I have configured the MX in Plesk to point to the new server and its working. However, when I try to send him mail I get the following error.

    Remote host said: 553 sorry, that domain isn't in my list of allowed rcpthosts; no valid cert for gatewaying (#5.7.1)

    To give you an idea on the infrastructure, this is how it is setup. (example IPs only)

    Plesk Server 1.2.3.4
    Mail server is also 1.2.3.4 -- I use this to send via Authenticated SMTP

    Customers new mail server 5.6.7.8

    When I try to send mail, my server (1.2.3.4) bounces back with that above error. I have also switched off mail services for that domain.

    What am I missing??

    Cheers
    John
     
  2. Arun V

    Arun V New Pleskian

    13
    35%
    Joined:
    Dec 23, 2011
    Messages:
    18
    Likes Received:
    0
    # is that domain listed in /var/qmail/control/rcpthosts ?
    # did you try running mcheck to reset qmail settings?
     
  3. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Edit the file

    Code:
    vim /var/qmail/control/virtualdomains
    In it delete the domain name that you don't host mail on that plesk server
     
Loading...