• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

mchk in plesk on ubuntu 12.04LTS corrupts vmailbox.db of postfix

Hello,

After a upgrade, where i had some mailissues after, i issued mchk, but after that i noticed that e-mail addressed to <mailbox>@domain.tld was nog working anymore.

Further investigation lead me that /var/spool/postfix/plesk/vmailbox.db was 'empty' output when issuing the command : postmap -s /var/spool/postfix/plesk/vmailbox.db

I tried this on a test server as well with the same result.

I did recreate the file with some database / scripting skills but this is not a nice result of mchk command.
 
Hi Silvester van der Leer,

such issues with the "mchk" - utility may occur, when there are mailboxes with empty passwords. In such cases, the mail-auth_dump will exit with an error.
To check eMail - accounts with empy passwords, you may use the mysql - command:
Code:
mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa
select displayName,password from accounts join mail on mail.account_id = accounts.id JOIN domains ON mail.dom_id = domains.id where type="sym" and password not like "$AES%";
Please correct the missing passwords by reseting them over your Plesk Control Panel and afterwards an additional "/usr/local/psa/admin/sbin/mchk --with-spam" should result with no errors.

If you experience further issues/errors/problems, please reply with corresponding entries from your mail.log.
 
Hi,

I've checked the empty passwords ofcourse, mail-auth_dump is not exiting with errors, but /var/spool/postfix/plesk/vmailbox.db was completely empty after mchk
no mailbox was listed at all when checking with postmap -s vmailbox

mail-auth_dump was listing all accounts
 
Back
Top