1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Migrate from Plesk 8.6 to 9.0.1 - IP mapping?

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Hein Tore Tonnesen, Mar 30, 2009.

  1. Hein Tore Tonnesen

    Hein Tore Tonnesen Guest

    0
     
    I've successfully managed to back up a domain hosted on a Plesk 8.6 installation, uploaded it to my new server, and converted the dump to prepare it for 9.0.1 using the following command:

    9.0.1's Backup Managed detects the dump, and I can click on it to start the restoration process. However, after clicking "Restore", I'm taken to a new page that says "New IP addresses: IP address not found". It gives me the option to upload an IP mapping file (until this point I didn't even know what this was ...), but it doesn't seem to like any of my files (tried with 10 different ones, everything from simple <oldip> -> <newip> to way more complicated ones.)

    I Google some more, and come across a forum thread that suggests changing the old IP address to the new one in the converted XML file, from the dump.

    Again: no go. Same thing happens, apart from that my new IP address is (logically) listed under "Old IP Addresses".

    So where do I go from here? Would backing up the old server or just a client be a simpler task, or would that too give the same annoying outcome?

    Any suggestions are most appreciated; right now I have a server which I cannot use, although I would very much like to.

    Thanks!
     
  2. Welber Oliveira

    Welber Oliveira Guest

    0
     
    I had the same problem, in my case I had both of my IP adresses set as <exclusive>, after trying all sorts of things I decided to add another IP but this time as <shared> with that set up I try do restore my backup againg and the shared IP was avaliable at the IP mapping screen and the restore was successfully made.
     
  3. Hein Tore Tonnesen

    Hein Tore Tonnesen Guest

    0
     
    This is what the IP Addresses page tells me:

    So if I interpret this correctly, your solution is not an option for me?
     
    Last edited by a moderator: Mar 31, 2009
  4. albans

    albans Regular Pleskian

    26
     
    Joined:
    Nov 29, 2005
    Messages:
    173
    Likes Received:
    0
    I ran exactly in the same problem... Finally, I defined the IP type directly in the MySQL database!
    Simply log as MySQL admin (you can do it via the server-wide Database settings in Plesk), open the "psa" database, go to the ip_pool table, then you can modify the type to shared.

    Then I had no problem getting the full-server backup!
     
  5. Hein Tore Tonnesen

    Hein Tore Tonnesen Guest

    0
     
    Thank you!

    Your solution seems to work for me as well. So far, no errors :)
     
Loading...