1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Migrate mailman list to new domain

Discussion in 'Plesk for Linux - 8.x and Older' started by Gustave Stresen-Reuter, Apr 20, 2009.

  1. I've tried following a variation on these instructions for migrating a mailman list[1] to a new domain, but I was unable to send/receive messages after the move. Specifically, messages were sent, no error was returned, but the messages never made it to the list.

    Additionally, there is a complication with the instructions. The list address for lists created by Plesk are usually of the format listname@domain.tld but the instructions include a line that would convert the address to listname@lists.domain.tld.

    So, in short, I'm wondering if anyone can guide me on moving an active mailing list from one domain to another (without having to recreate the list settings, membership, etc.).

    Thanks in advance.

    Ted Stresen-Reuter
    1* http://www.debian-administration.org/articles/567
  2. greyman56

    greyman56 Guest

    Did you figure this out Ted? Would love to hear how you got it working.

  3. Migrate mailman list to new domain on same machine

    No, I never did get it figured out. I did try testing a few things and although I never actually did get it done. Here is what I tried:

    1. Copy all of your mailman folders for the selected list to a temp directory (subscribers, archives, and configuration of the list)
    2. Delete the list from the Plesk CP
    3. Create the list under the new domain
    4. Copy the mailman files in the temp dir to the new folders

    I was unable to get it to work. The issue I experienced was that emails were not making it to (or being picked up by) the new list. I'm not sure what I was doing wrong but I suspect it had something to do with the hostname being stored in some of the configuration files. There is a command available to update the hostname, but I'm unfamiliar with what it is.