• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Migration 9.5 to 10.3.1 fails

C

christoph_peter

Guest
I try to migrate a reseller account from 9.5 to 10.3.1 - I do not have root access to the source server. I created a backup via the web interace. uploaded it the new server via the backup manager or directly via ssh. I used this

http://kb.parallels.com/en/9578 to convert the backup.

usr/local/psa/admin/bin/pmm-ras --import-file-as-dump --dump-file-specification=./backup_c.peter_info_1112121210.xml.tgz --dump-storage=/var/lib/psa/dumps/ --guid=00000000-0000-0000-0000-000000000000 --type=server --session-path=/usr/local/psa/PMM/logs
resellers/c.peter/backup_c.peter_info_1112121210.xml

when restoring the backup it fails with the following error:

ERROR: () Failed validation of the document with its internal DTD. The errors are: Element 'preferences': This element is not expected. Expected is ( limits-and-permissions )

any ideas on how to fix this?
 
There is database inconsistency which can be fixed manually in database. There is similar problem described in KB article http://kb.parallels.com/9343 You can try to locate and fix this problem in Plesk database. Contact Parallels Support Team if you can't do it by yourself.
 
Thanks for the info, the article addresses two other specific issues, but without knowing the exact query to run against the database I can't really do anything. Also as I said before, I don't have root access to the Server / Plesk installation. Is there a way I can get more detailed info on the fix so I can pass it on to my provider?
 
Back
Top