1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Migration API broken in 10.4.4?

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by cmadams, Jan 30, 2012.

  1. cmadams

    cmadams Guest

    0
     
    I built a new server running RHEL 6 and Plesk 10.4.4 (MU14), and I'm trying to migrate several hundred sites from an old Plesk 8 server. I'm trying to script the migration (because there are a bunch of things that have to be done after the Plesk Migration Manager finishes), but the PMM API call isn't working. I get an internal server error, and sw-cp-server/error_log has:

    2012-01-27 13:30:34: (mod_fastcgi.c.2588) FastCGI-stderr: PHP Fatal error: Class 'Db_Table_Broker_ServiceNode' not found in /usr/local/psa/admin/plib/Db/Table/Broker.php on line 42

    There's a post from a month ago over in the Developer/Plesk API forum about this, but it doesn't have any response.

    If that isn't going to get fixed, does anybody know of another scriptable way to perform migrations? I looked at the pmmcli utility, but I didn't find any documentation and couldn't figure out the correct input/arguments/order of operations.
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
Loading...