1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Migration errors and solutions

Discussion in 'Plesk for Linux - 8.x and Older' started by alirizvi55, Mar 25, 2005.

  1. alirizvi55

    alirizvi55 Guest

    0
     
    Hello folks,

    The migration manager, when it works, is the easiest/fastest way to migrate sites over to Plesk.

    However, I encountered some problems with the process.

    Here are the problems and fixes:

    I wanted to migrate about 25 domains from a Plesk 7.1 reloaded server to my new Plesk 7.5.2 reloaded server at 1and1.com.

    Problem#1: Most of the domains were less than 50MB but one of 'em was about 900MB. It would just not complete the transfer and would seem to hang up with 2% left.

    Solution#1: While the transfer is hung up, ssh into your source server and go to the directory that has all the files to be transferred. This directory should be in /root/migration. Tar all these files into one big file using:
    tar -cf allfiles.tar *
    (copy paste to make sure spaces are present)
    Get this file into the /usr/local/psa/PMM/archives
    directory of the destination server and extract files using:
    tar -xf allfiles.tar
    You can now delete the allfiles.tar file. Assuming the migration on the destination server is still hung up, cancel the migration, and on the Migration Agent Upload screen, select Import mode, and click Next. If you get the "Importing data from localhost" screen, you should be good to go... unless you hit another problem described below.

    Problem #2: I get the error:
    Unable to convert the data to Plesk format:
    Unable to convert the data to Plesk format:"
    This was because some of my domains were using mailman Mailing lists. Simply delete the mailing lists from those domains (after saving the lists of email addresses some place else). Now start over.

    Problem #3: When I try to restart the migration process, it gave me this:

    Incorrect migration.status file format. Not support status "transfer"
    0: /usr/local/psa/admin/plib/PMM/MigrationUploadAgent.php:261 psaerror(string "Incorrect migration.status file format. Not support status "transfer"")
    1: /usr/local/psa/admin/plib/PMM/MigrationUploadAgentInfoForm.php:42 migrationuploadagent->getmigstatusmsg()
    2: /usr/local/psa/admin/htdocs/server/PMM/index.php:22 migrationuploadagentinfoform->assign(object of type migrationuploadagent)
    Solution#3: Delete all files from
    /usr/local/psa/PMM/var and
    /usr/local/psa/PMM/archives
    Then go back to Plesk and click on Migration Manager and you should be able to start from scratch.

    Hope this helps somebody. Also hope these issues get resolved in a (near) future release of Plesk.

    Best wishes and peace,
    Ali
     
  2. dm__@

    dm__@ Guest

    0
     
    When I run into (fixed by myself) similar troubles, I contacted Plesk support team. They passed the problem to the development team, and developers checked configuration on my old server and fixed the problem in the next release. You may also help in "permanent" fixing the problems you found if your old server is still running.
     
  3. superbock

    superbock Guest

    0
     
    Hi!

    I'm experiencing the hanged transfer problem, migrating a website with around 900MB total from 7.0.4 to 7.5.2.

    I'll try again tomorrow with your solution, but i'd like to know first if Plesk released a clean solution for this meanwhile.

    Tks a lot for sharing your experience.

    Best regards
     
  4. dofni

    dofni Guest

    0
     
    I tried solution three and deleted all the information in the /var and /archive folders.

    I now receive this error:

    File migration.result not exist.

    --------------------------------------------------------------------------------

    0: /usr/local/psa/admin/plib/PMM/MigrationExec.php:100 psaerror(string "File migration.result not exist.")
    1: /usr/local/psa/admin/plib/PMM/MigrationDeployer.php:564 migrationdeployer->issuccess()
    2: /usr/local/psa/admin/plib/PMM/MigrationDeploy.php:101 migrationdeployer->getresult()
    3: /usr/local/psa/admin/plib/PMM/MigrationDeployEndInfoForm.php:38 migrationdeploy->getendmsg()
    4: /usr/local/psa/admin/htdocs/server/PMM/index.php:20 migrationdeployendinfoform->assign(object of type migrationdeploy)

    What can I do to get the tool in working condition. I do not have any buttons on my control panel. Just this eror text.
     
  5. dm__@

    dm__@ Guest

    0
     
    It helped me to delete all the rows from the mysql table 'PMM'.
     
  6. TDuncklee

    TDuncklee Guest

    0
     
    In attempting to migrate from FreeBSD 4.8/Plesk 6.1 to FreeBSD 5.3/Plesk 7.5.3 I’m having two problems:
    1) I seem to always get errors relating to crontab even when the domain being migrated has no crotab entries.
    Code:
       1. Execution of '/usr/local/psa/admin/sbin/crontabmng' 'set' 'new2' '/tmp/pmm-temp-MisjBc' failed with the return code 1.
          STDOUT:
    
          crontabmnt syntax:
          get <username>
          to show cronatb of <username>
          set <username> <filename>
          to set cronatb of <username> from <filename>
          allow <username>
          to allow cronatb of <username>
          deny <username>
          to deny cronatb of <username>
          remove <username>
          to remove cronatb of <username>
          rename <username> <newusername>
          to rename cronatb of <username> to <newusername>
          System error: crontab execution error
    
          STDERR:
          "/tmp/pmm-temp-MisjBc":2: bad day-of-month
          crontab: errors in crontab file, can't install
          System error: crontab execution error
    
    
    2) Even though databases are created none of the structure or data is copied over.

    Any ideas?
    Thanks,
    Tim
     
Loading...