1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Migration Manager doesn't connect to agent.

Discussion in 'Plesk for Windows - 8.x and Older' started by vlurk, Mar 1, 2007.

  1. vlurk

    vlurk Guest

    0
     
    Hello,

    I'm trying to migrate from a Windows Server running Plesk 7.6 to another with Plesk 8.1. Everything is working properly, file and printer sharing installed on both, firewall correctly configured (even a port scan says it is so...).

    On the Plesk destination server, I get the following error from the Migration.Log file:
    Code:
    Debug	03/01/2007 16:22:39 : Start migrmng execution in --deploy-scout mode
    Debug	03/01/2007 16:22:39 : AdministratorPassword
    Debug	03/01/2007 16:22:39 : Try to deploy scout to: tcp://somehostname.com:6489/WinAgentURI
    Debug	03/01/2007 16:22:39 : migrmng::DeployScout begin (sytemType = Windows)
    Debug	03/01/2007 16:22:39 : MigratorConfigsManager::GetMigratorManager find Migrator Manager file:C:\Program Files\SWsoft\Plesk\PMM\PsaMigrMng80.dll
    Debug	03/01/2007 16:22:39 : MigrMng75::Load begin (workDirectory=C:\Program Files\SWsoft\Plesk\PMM, configName=Main)
    Debug	03/01/2007 16:22:39 : MigrMng75::Load successfully finished
    Debug	03/01/2007 16:22:39 : MigrMng75::DeployScout begin (hostName=somehostname.com)
    Info	03/01/2007 16:22:39 : CrossSysAgent::DeployScout SystemType=(Windows) URI=(tcp://somehostname.com:6489/WinAgentURI) 
    Info	03/01/2007 16:22:39 : CrossSysAgent::deployScoutToWindowsHost Try to deploy scout to remote Windows host (somehostname.com)
    Error	03/01/2007 16:23:06 : CrossSysAgent::deployScoutToWindowsHost Unable to deploy scout to remote Windows host (somehostname.com). Exception processed (System.ComponentModel.Win32Exception: No network provider accepted the given network path
       at ForeignMigratorCore.RemoteWinConnection.ConnectToNetworkResource(ConnectionParameters connParams, String resourceName)
       at CrossSysAgentSup.CrossSysAgent.deployScoutToWindowsHost(ConnectionParameters connParams)) 
    Debug	03/01/2007 16:23:06 : CrossSysAgent::deployScoutToWindowsHost finished with error
    Debug	03/01/2007 16:23:06 : ForeignMigratorCore.MigratorException: Unable to connect to remote host somehostname.com. Please check if the remote server is available for connection and if the correct login and password are specified.
       at PsaMigrMng75.MigrMng75.DeployScout(ConnectionParameters connParams)
       at migrmng.App.DeployScout(ConnectionParameters connParams)
       at migrmng.App.Main(String[] args)
    Debug	03/01/2007 16:23:06 : migrmng exits with code -1
    Debug	03/01/2007 16:23:06 : Unload domain.
     
  2. vlurk

    vlurk Guest

    0
     
    Also, I get the same error even if I try to use the HTTP channel. (I posted my last attempt using TCP). Of course, I always configure the same channel on both the agent and the destination server.

    But anyways, the error really looks like I'm missing a software component:
    Code:
    System.ComponentModel.Win32Exception: No network provider accepted the given network path
    .

    Anyone has an idea what's wrong/missing?
     
  3. Andrey Kareev

    Andrey Kareev Guest

    0
     
    Hello,

    Please, try to migrate using IP address instead of host name. If this will fail try to connect from the Plesk server to the share folder on the remote server with the following path \\XXX.XXX.XXX.XXX\ADMIN$ (replace XXX.XXX.XXX.XXX with the actual IP address of your remote server). If connection failed you should test necessary services on both servers, availability of system shares on remote server like ADMIN$, c$, etc.
    If all settings are OK please send request to SWsoft support, or contact me with e-mail and we'll examine your sitaution closely.

    Thanks.
     
  4. vlurk

    vlurk Guest

    0
     
    Well, it seems like this kind of URI isn't expected by the piece of software that initiate the connection. Here's what I get following your suggestion:

    Code:
    Debug	03/02/2007 10:08:37 : Start migrmng execution in --deploy-scout mode
    Debug	03/02/2007 10:08:37 : System.UriFormatException: Invalid URI: The format of the URI could not be determined.
       at System.Uri.Parse()
       at System.Uri..ctor(String uriString, Boolean dontEscape)
       at System.Uri..ctor(String uriString)
       at System.UriBuilder.get_Uri()
       at migrmng.App.ExtractConnectionParameters(CmdArgsParser parser)
       at migrmng.App.Main(String[] args)
    Debug	03/02/2007 10:08:37 : migrmng exits with code -1
    Debug	03/02/2007 10:08:38 : Unload domain.
    But the services and the share are available, indeed. The results of a "net share" :
    Code:
    C:\Documents and Settings\Administrator>net share
    
    Share name   Resource                        Remark
    
    -------------------------------------------------------------------------------
    IPC$                                         Remote IPC
    ADMIN$       C:\WINDOWS                      Remote Admin
    D$           D:\                             Default share
    C$           C:\                             Default share
    The command completed successfully.
    I got the solution to my problem though. I will post it later: I must do some work now.
     
  5. vlurk

    vlurk Guest

    0
     
    Everything looks alright now: we have successfully moved 4 domains. But the real big migration (70+ domains) has yet to come.

    The problem I had was that the destination server had one of the network interfaces configured with an IP adress on the local subnet of the source server. But the machines weren't on the same LAN during my tests.
    I noticed the "forgotten ip", one of many for that interface, when I used Wireshark and saw outgoing ARP requests for the source server's IP. :rolleyes:

    I can't believe I didn't try Wireshark before. What a waste of time...
     
  6. Kenan

    Kenan Basic Pleskian

    18
    60%
    Joined:
    Aug 22, 2010
    Messages:
    40
    Likes Received:
    0
    Please help me vlurk

    Hi vlurk,

    We have been use Plesk 10.4.4 on our Windows server. We bought a new Windows server and we would like to transfer our customers, domains and reseller to new server. We would like use same plesk (10.4.4) and installed now on new server but we have the following an error and could not fixed;

    "Connection to host is not available or migration agent is not running on the source host."

    We tried to migration but we have this error. We read all informatio─▒n about it in Plesk migration guide but did not work.

    I searched all posts about this in parallels forum, and i done all suggestions but i couldn't connect to source server.

    Please help me!
     
Loading...