• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Migration manager is NOT migrating ALL IMAP folders.

i have the same problem: mail forwading not migrated

migrating from plesk 9.0.1 to plesk 10.0.1

mail forwarding are not copied.

the forwarding is correctly migrated only when the forwarding was to a list of several addresses (that forward feature was called " Mail group" in plesk 9.0.1. the forwarding for emails that were forwarded to a single address with the "Mail redirects" feature of plesk 9.0.1 are not migrated.

this is indeed very annoying.

i can see that in plesk 10.0.1 there is only one mail forwarding feature (whether it is for 1 or multiple emails). but migration should consolidate all mail forwarding correctly in the destination system.

i also get the following error for mail accounts that have a mailbox on the source system:

Failed deployment of mail user [email protected]

Execution of /usr/local/psa/admin/plib/api-cli/mail.php --create [email protected] -passwd -mailbox true failed with return code 1.
Stderr is
An error occured during mailname creation: Can't create mailname:
Wrong syntax for option's '-passwd' parameter

Execution of /usr/local/psa/admin/plib/api-cli/maillist.php --update-service xxxxx.com -status enabled failed with return code 1.
Stderr is
Mailing list support is not installed or not properly configured.

not sure why i would need to install or configure "Mailing list support" on the target system (it was not used on the source system), but i read somewhere that configuring MailMan on the target system may work around that problem.
 
the error:
Wrong syntax for option's '-passwd' parameter

seems to happen if the mailbox password on the source server contains a space or some other special character. i changed the password of this mailbox on the source server, and this resolved this error.
 
Back
Top