1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Missing nameservers 2.

Discussion in 'Plesk for Linux - 8.x and Older' started by thastudio, Jul 12, 2005.

  1. thastudio

    thastudio Guest

    0
     
    Hello

    I have used Plesk a lot of times and never had any problems setting up the nameservers but this is wat happend on my new dedicated server.

    I have 3 IP-addresses:
    213.148.255.64 (master)
    213.148.255.65
    213.148.255.66

    I created nameservers on my primary domainname:
    thastudio.be. NS ns1.thastudio.be.
    thastudio.be. NS ns2.thastudio.be.
    thastudio.be. A 213.148.255.64
    webmail.thastudio.be. A 213.148.255.64
    mail.thastudio.be. A 213.148.255.64
    ns1.thastudio.be. A 213.148.255.64
    ns2.thastudio.be. A 213.148.255.65
    ftp.thastudio.be. CNAME thastudio.be.
    www.thastudio.be. CNAME thastudio.be.
    thastudio.be. MX (10) mail.thastudio.be.
    thastudio.be. MX (20) esli.wesowe-is.nl.
    213.148.255.64 / 24 PTR thastudio.be.

    And for the other domainnames I use the following DNS settings:
    <domain>. NS ns1.thastudio.be.
    <domain>. NS ns2.thastudio.be.
    <domain>. A <ip>
    webmail.<domain>. A <ip>
    mail.<domain>. A <ip>
    ftp.<domain>. CNAME <domain>.
    www.<domain>. CNAME <domain>.
    <domain>. MX (10) mail.<domain>.
    <domain>. MX (20) esli.wesowe-is.nl.
    <ip> / 24 PTR <domain>.

    When I use ns1.thastudio.be and ns2.thastudio.be as nameservers for the domainname thastudio.be everything works just fine. But when I use the same nameservers to the other domainnames I get no connection to it, this is what dnsreport.com gives as errors on blueolive.be (a client on my server that uses the settings like above):
    - Missing nameservers 2
    ERROR: One or more of the nameservers listed at the parent servers are not listed as NS records at your nameservers. The problem NS records are: ns2.thastudio.be.

    - MX Category
    ERROR: I couldn't find any MX records for blueolive.be. If you want to receive E-mail on this domain, you should have MX record(s). Without any MX records, mailservers should attempt to deliver mail to the A record for blueolive.be. I can't continue in a case like this, so I'm assuming you don't receive mail on this domain.

    - Connect to mail servers
    ERROR: I could not find any mailservers for blueolive.be.

    - WWW Category
    ERROR: I couldn't find any A records for www.blueolive.be. But I did find a referral to ns1.thastudio.be. (and maybe others). If you want a website at www.blueolive.be, you will need an A record for www.blueolive.be. If you do not want a website at www.blueolive.be, you can ignore this error.

    Do I do something wrong? I have no possibilities to test anymore because all my clients would have downtime when it doesn't work... So I need a solution that would work for 100% sure...


    Thanks in advance
    Niels Trescinski
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If you run a dnsreport.com on your own main domain, you will see a difference in your IPs for ns1 and ns2 from what you have posted they should be:

    Your NS records at the parent servers are:

    ns1.thastudio.be. [213.148.255.65] [TTL=86400] [NL]
    ns2.thastudio.be. [213.148.255.66] [TTL=86400] [NL]

    [These were obtained from paris.ns.dns.be]

    And Mismatched Glue error:

    Mismatched glue ERROR: Your nameservers report glue that is different from what the parent servers report. This will cause DNS servers to get confused; some may go to the IP provided by the parent servers, while others may get to the ones provided by your authoritative DNS servers. Problem record(s) are:

    ns1.thastudio.be.:
    Parent server (paris.ns.dns.be) says A record is 213.148.255.65, but
    authoritative DNS server (213.148.255.65) says it is 213.148.255.64
    ns2.thastudio.be.:
    Parent server (paris.ns.dns.be) says A record is 213.148.255.66, but
    authoritative DNS server (213.148.255.65) says it is 213.148.255.65
    ns1.thastudio.be.:
    Parent server (paris.ns.dns.be) says A record is 213.148.255.65, but
    authoritative DNS server (213.148.255.66) says it is 213.148.255.64
    ns2.thastudio.be.:
    Parent server (paris.ns.dns.be) says A record is 213.148.255.66, but
    authoritative DNS server (213.148.255.66) says it is 213.148.255.65
     
  3. thastudio

    thastudio Guest

    0
     
    Sorry, forgot to tell you that thastudio.be allready is changed back to the original setting to the previous settings.
    But you see settings that I tried out earlier this week.

    With the settings you see in my first post I had no single problem with dnsreport...
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Yes, but as of *right now* your dnsreport has critical errors which will impact things.

    If you mean that you have changed your ns1/ns2 back to .64/.65, then the changes either have not propagated yet, or something went wrong when you submitted the nameserver IP changes at your registrar.

    The fact that *right now* the DNS which is showing up on reports from *outside* your server are showing wrong IPs, this will affect your domain and hosted domains until it is cleared up or propagated.
     
  5. thastudio

    thastudio Guest

    0
     
    Ok maybe I didn't explained this enough, so let me do it now:
    - few days ago I used all the settings from my first post;
    - it seemed that this settings resulted in the errors I explained in my first post;
    - afterwards I tried some other things and the errors you mention (for thastudio.be) is the last thing I tried, if you look right now you see that thastudio.be is linked to other nameservers (the server I want to move from) and that he gives no errors...
     
Loading...