1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

modules error

Discussion in 'Plesk for Linux - 8.x and Older' started by webviva, Dec 1, 2008.

  1. webviva

    webviva Guest

    0
     
    I have plesk 8.6 with recent patches...
    Now when I try to activate a new filter for firewall module the followind error message appears:
    "proc_close() failed: mktime() [<a href='function.mktime'>function.mktime</a>]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead".


    On the other hand. If I try to enable the services monitoring management from watchdog module I have this error message:

    "Error: Error occurred while calling the module utility wdservice: 'Empty error message from utility.'"

    If I try to execute the a rkhunter security scan from plesk the error says:

    Error occurred while calling the module utility securscan: 'Empty error message from utility.'
    --------------------------------------------------------------------------------
    0: /usr/local/psa/admin/plib/modules/watchdog/wdlib.php:1278
    wd__exec_wd_util(string 'securscan', array, array)
    1: /usr/local/psa/admin/htdocs/modules/watchdog/secur-scan.php:24



    I have reinstalled the watchdog module and all is correct:
    Downloading the file PSA_8.6.0/dist-rpm-SuSE-10.1-i386/opt/modules/watchdog/psa-watchdog-2.0.3-suse10.1.build86080912.20.i586.rpm: skipped because of md5 checksum match.
    Starting installation of packages
    prepareInstallStep: resolve results for package(s):
    (s) system_installed_psa-8.6.0-suse10.1.build86080722.02.i586.rpm
    (s) system_installed_bash-3.1-24.3.i586.rpm
    (s) system_installed_perl-5.8.8-14.7.i586.rpm
    (s) system_installed_glibc-2.4-31.1.i686.rpm
    (s) system_installed_openssl-0.9.8a-18.23.i586.rpm
    (s) system_installed_libgcc-4.1.2_20070115-0.14.i586.rpm
    (s) system_installed_libidn-0.6.0-14.i586.rpm
    (s) system_installed_libstdc++-4.1.0-25.i586.rpm
    (s) system_installed_zlib-1.2.3-13.i586.rpm
    Installing the package psa-watchdog-2.0.3-suse10.1.build86080912.20.i586
    Trying to start MySQL server... Trying to establish test connection... connected
    done
    ===> Checking database
    Trying to start MySQL server... Trying to establish test connection... connected
    done
    ===> Setting up file owners
    ===> Installing database
    ===> Set up monitrc_vz.tpl as template for monitrc
    ===> Registering module
    The packages were installed successfully.



    but the problems remains...

    Anybody has similar problems?
    :(
     
  2. webviva

    webviva Guest

    0
     
    I've found the problem (or at least part of the problem). My /usr/local/psa/admin/sbin/mod_wrapper is corrupted...
    Somebody knows how I can find a correct version of this file (I use Suse 10.1 + Plesk 8.6)
    :(
     
  3. webviva

    webviva Guest

    0
     
    Solved!

    I post here the solution (perhaps it will be a help for someone in the future)

    The problem was a corrupted /usr/local/psa/admin/sbin/mod_wrapper file...

    I have extrated the corect one from psa-8.6.0-suse10.1.build86080722.02.i586.rpm
    following http://www.linux-noob.com/forums/lofiversion/index.php/t355.html
     
Loading...