1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Multiple PHP versions

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Pagemakers, Jan 6, 2012.

  1. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    PHP 5.1 installed on my Plesk CENT OS server.

    I am happy to keep 5.1 on the server CP and for the domains but one domain on the server needs PHP 5.3+

    Is there a way to do this or will it mess up anything else?

    Any pointers would be appreciated.
     
  2. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    Can anybody help?
     
  3. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    Pretty please...
     
  4. kram@

    kram@ Regular Pleskian

    26
    40%
    Joined:
    Dec 11, 2003
    Messages:
    152
    Likes Received:
    2
    Location:
    South Africa
    Php 5.3.3

    @Pagemakers

    PHP 4, 5.0, 5.1 and 5.2 are end-of-life products.
    You should upgrade to 5.3.3
     
  5. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    I’m happy to leave 5.1 running Plesk and the remainder of the domains. My question can/how do I installed 5.3.3 on one domain only?

    I am apprehensive about upgrading everything to 5.3.3 incase it breaks Plesk and stops some other domains from working because they may be incompatible to 5.1

    The server is only accessible by us. It is not used to allow our customers access.
     
  6. kram@

    kram@ Regular Pleskian

    26
    40%
    Joined:
    Dec 11, 2003
    Messages:
    152
    Likes Received:
    2
    Location:
    South Africa
    In my Experience, upgarding to 5.3 has very liitle impact on hosted domains.
    We focus mostly on Joomla! hosting and only had some minor issues with J 1.0.
    Had no reports of other issues from any other clients.

    As far as Plesk goes - have had no issue at all moving to 5.3.8
    Everythign runs smooth and dandy.

    Re your orginial question:
    I am not sure of how to allow two version of PHP on one server.
     
  7. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    Thank you very much for your advice.
     
  8. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    Do you mean 5.3.3? You say 5.3.8
     
  9. kram@

    kram@ Regular Pleskian

    26
    40%
    Joined:
    Dec 11, 2003
    Messages:
    152
    Likes Received:
    2
    Location:
    South Africa
    Php 5.3.8

    I am running 5.3.8 on PLESK 10.4.4 MU#10

    PHP 5.3.8 (cli) (built: Oct 31 2011 18:33:53)
    Copyright (c) 1997-2011 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
    with the ionCube PHP Loader v4.0.10, Copyright (c) 2002-2011, by ionCube Ltd., and
    with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
     
Loading...